Results 1 to 8 of 8
  1. #1

    05 rxt shuts off at WOT

    Anyone can help. Ski runs fine idles fine but once you go WOT after about 10 second s it just shuts off completely. No warning light and starts right up. I'm thinking IC might be the problem after doing some research in here. Wanted to ask the you guys on your input. Ski completely stock. Thanks


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    fuel pump?

  3. #3

    Join Date
    May 2009
    Location
    Broadstairs, Kent, England
    Posts
    138
    +1
    2
    Check the fuel pressure when it's cuts out (unscrew the fuel pressure relief valve on the fuel hose that connects to the fuel rail and poke the valve) - it should squirt out fuel (use a rag so it doesn't get you in the face). If there's no pressure then it could be the fuel pump.

  4. #4
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    use a gage on the port on the fuel line
    is a much safer way to check the psi

  5. #5
    Ok.i do have a gauge I can put on for testing. . What pressure at idle? Hope it's just fuel pump. Thanks for response guys

  6. #6
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    does your dash gauges go dead, when it stalls?

    Dess post issue maybe?


    Or does it sputter, run bad, then stall

  7. #7
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    56-60psi all the time

  8. #8
    Quote Originally Posted by psycho rxp View Post
    does your dash gauges go dead, when it stalls?

    Dess post issue maybe?


    Or does it sputter, run bad, then stall
    No sputter. Runs good dash stays on only rpm needle dies. Can start right up. I'm going to replace the fuel pump. I'm sure it's never been done. Start from there and see what happens. Will test this old one out first. Hopefully I found my issue

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with 03 GTX shutting off at WOT
    By 03gtx in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-09-2014, 11:40 PM
  2. 96' SPX - Shutting Off at Full Throttle - Why??
    By BartenderSmalley in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 08-05-2008, 08:29 PM
  3. Fell off at WOT
    By TurboJimmy in forum High Performance Watercraft Safety
    Replies: 85
    Last Post: 07-13-2008, 07:11 PM
  4. GP 1300 R shut off at 35 mph ??
    By MIARider in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 12-05-2007, 11:49 PM
  5. Fell off at WOT
    By TurboJimmy in forum Kawasaki Open Discussion
    Replies: 56
    Last Post: 09-13-2007, 01:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •