Results 1 to 5 of 5
  1. #1

    supercharger ate itself.



    I guess I will be pulling the pto housing to look for the rest of that bearing and any other debris that might be in the engine. Any other tips or suggestions? The charger was just rebuilt 30 hours ago. Any insight as to why the bearing would fail so soon?


  2. #2
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,378
    +1
    981
    Check both oil pump screens.

    After the charger was rebuilt did you recheck the slip after 10-15 hours?

  3. #3
    Will do. Checked slip right around 15 hours after it was built. Had 85 inch lbs. Added the heavy duty riva spring washers then this happened.

  4. #4
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Stock charger?

    Is the housing/wheel dmagaed?

  5. #5
    Yes stock charger. The housing and wheel are toasted.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Motor ate itself
    By eb87 in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-28-2016, 11:56 AM
  2. 750 SL ate itself today
    By seaobin in forum Polaris Open Discussion
    Replies: 11
    Last Post: 04-10-2011, 09:09 PM
  3. Additional Shim for Supercharger Clutch
    By johnD in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-24-2009, 09:55 PM
  4. Supercharger Impeller Install
    By Teflon in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-09-2005, 06:01 PM
  5. SuperCharger Imp Install hours away
    By CRAZEDRXP in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-06-2005, 06:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •