Results 1 to 7 of 7
  1. #1

    Installing ride plate

    Hi guys. Finally getting the rebuilt pump from Impros tomorrow. I was wondering if i need to use some sort of sealer on the bolts when i put the ride plate back on? I also saw the the ride plate had silicone sealer around the edges when i took it off. Do i need to seal that as it was sealed before i too it off? Thaks.


  2. #2
    DH300's Avatar
    Join Date
    May 2013
    Location
    Alabama
    Posts
    1,149
    +1
    217
    I'd put silicone around the edges for sure.

  3. #3
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Blue locktight on the threads and silicone is not needed. Just more work next time you want to remove it. I have not used silicone since the first plate change

  4. +1 by:


  5. #4
    Oheezy404's Avatar
    Join Date
    Jan 2014
    Location
    Kansas
    Posts
    238
    +1
    21
    Quote Originally Posted by jonyv1 View Post
    Hi guys. Finally getting the rebuilt pump from Impros tomorrow. I was wondering if i need to use some sort of sealer on the bolts when i put the ride plate back on? I also saw the the ride plate had silicone sealer around the edges when i took it off. Do i need to seal that as it was sealed before i too it off? Thaks.
    Now would bet a great time to add a Solas impeller a after market intake grate and ride plate and pump shoe kit. (:

  6. #5
    Spooling's Avatar
    Join Date
    Sep 2011
    Location
    West Coast of Florida
    Posts
    1,283
    +1
    177
    Quote Originally Posted by lasportsmn View Post
    Blue locktight on the threads and silicone is not needed. Just more work next time you want to remove it. I have not used silicone since the first plate change
    ----------------------
    I used to seal the Ultra-150 plate I had with silicone - yet never used that stuff on my Ultra-300x and everything's fine.

    BTW Kawasaki does not use silicone on their Ultra-300x ride plates OEM.

    Good Luck !!!

  7. #6
    Speed Junkie UnleashedBeast's Avatar
    Join Date
    May 2007
    Location
    Pensacola, Fl.
    Posts
    760
    +1
    172
    Quote Originally Posted by Spooling View Post

    BTW Kawasaki does not use silicone on their Ultra-300x ride plates OEM.
    My stock 2015 310X had the entire ride plate and grate sealed with silicone.

  8. +1 by:


  9. #7
    Gsmith88's Avatar
    Join Date
    Mar 2015
    Location
    Li , New York
    Posts
    834
    +1
    104
    Mine did too. Put locktite on the bolts and silicone the edges .. Takes an extra few minutes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installing Ride Plate
    By TheEngineer in forum 4-Tec Performance
    Replies: 6
    Last Post: 12-15-2012, 12:11 PM
  2. installing ride plate sealant???
    By Justplayinn in forum Polaris Open Discussion
    Replies: 9
    Last Post: 06-30-2011, 08:32 PM
  3. Installing ride plate
    By divin10 in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 02-12-2009, 09:23 PM
  4. Installing Jim's modded ride plate
    By Extrememotors in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-11-2008, 06:41 AM
  5. ride plate/intake grate installation
    By shooter98xpl in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 12-31-2005, 02:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •