Results 1 to 2 of 2
  1. #1

    Join Date
    Sep 2007
    Location
    sarnia ont
    Posts
    37

    1997 polaris sl 700 has no spark

    I'm repairing a 1997 sl 700 for a friend. Rebuilt the top end and when I went to fire it up there is no spark. Unit has a good battery, good ground to the electrical box. Voltage when cranking is 11.5vdc. I even tried a boost with no change. The ignition system is original, has not been updated. Coil, trigger and stator resistances are all in spec. I assume the cdi is bad. Should I bother trying a new cdi or should I just go ahead with the update kit? I'm a seadoo mechanic by trade but I'm not very familiar with polaris ignition systems.


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    It definitely wouldn't hurt to do the upgrade if you plan on keeping the ski.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. a friends sl 700 has no spark cdi problems
    By nickflo7 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 10-13-2013, 07:57 AM
  2. Which would you rather? 1994 Polaris Sl 750 or 1997 Polaris SL 700?
    By x2nervisx in forum Polaris Open Discussion
    Replies: 12
    Last Post: 02-24-2013, 01:12 PM
  3. Polaris SLT 700 Crank, No spark
    By 123slt700 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-06-2012, 08:44 PM
  4. Polaris SLT 700 Crank, No spark
    By 123slt700 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 04-27-2012, 10:45 PM
  5. 1997 polaris sl 700 no start issue
    By yamaha 1100 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 10-21-2008, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •