Results 1 to 7 of 7
  1. #1

    2006 rxp misfiring

    First run of the season my 2006 rxp is missing from 2000 to 3500 rpm you can hear it in the exhaust. Still has power and does 60
    limited by water conditions. Changed the plugs and the miss is still heard when running out of the water. Disconnected each coil
    connector and it ran worse with each one disconnected (eliminating a dead coil). Any ideas...


  2. #2
    redchev67's Avatar
    Join Date
    Apr 2012
    Location
    South Jersey
    Posts
    47
    +1
    2
    Next thing is to check fuel, unbolt rail with injectors and plug in your key, see if all 3 are flowing

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Bad fuel.
    Run some injection cleaner thru it.

  4. #4
    wow, you've been a member for 6 years and this is first post? quite the stalker yea, I had similiar on first run, changed fuel and plugs and was good to go!...even if plugs look fine and/or have low hours, try another set, sounds weird but sometimes works!
    Last edited by phumb; 06-10-2014 at 07:45 AM.

  5. #5
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    What I would do is take the coil's out.. and take the rubber boots off.... spray a carb cleaner on the end of a q-tip and clean the inside where the spark plugs snaps in.. They can get pretty gumed up over the years.
    http://www.greenhulk.net/forums/showthread.php?t=134732

  6. #6
    The misfire was caused by the blow off valve leaking. During the transition from vacuum to boost the valve leaked. Removed it and no problem.

  7. #7
    achavanne3's Avatar
    Join Date
    Jun 2014
    Location
    Louisiana
    Posts
    130
    +1
    7
    Quote Originally Posted by buda View Post
    The misfire was caused by the blow off valve leaking. During the transition from vacuum to boost the valve leaked. Removed it and no problem.
    Run some sea foam every 3 tank fulls

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 RXP only goes 4 MPH....
    By alib121185 in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-04-2008, 02:14 PM
  2. 2006 Rxp
    By Nitro4Life in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-26-2006, 10:44 AM
  3. 2006 RXP WHATS NEXT
    By DANNYA09 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-31-2006, 11:50 AM
  4. 2006 RXP...MUCH faster than I though!!!
    By ramnj in forum 4-Tec Performance
    Replies: 30
    Last Post: 04-18-2006, 02:22 AM
  5. 2006 RXP
    By ActionR32 in forum 4-Tec Performance
    Replies: 7
    Last Post: 10-04-2005, 11:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •