Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 40
  1. #1
    MikeB's Avatar
    Join Date
    Jan 2007
    Location
    Orlando, FL
    Posts
    278

    RPMs stuck at 6650

    I went out to the river today and noticed somehting was wrong right off the bat since I didn't hear the SC like usual. Im guessing that the washers are shot. Thankfully I have them already. Funny thing is last time I had the ski out it was running just fine, no problems and no hint of a loss of power. FYI, the ski was only in the water for less than 10 minutes.

    One question. I noticed that most people were only getting 6400 RPMs, is there any chance that the washers are still intact? I took the intake off and the SC whell spins freely with just a little force, not like a turbocharger where it will spin for some time.

    Once my roommate gets home with my sockets, figures he needs them the day I need them, the washers are going in along with a fresh oil change, RR SC wheel and putting in the 14/19r Ive had laying here for a while now.

    Everyone say a prayer for me not to tear apart this engine.


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Unfortunately you will find one of the washers missing off the shaft. Now you have to remove your front oil pump and inspect for damages. Hopefully you didn't put more than a couple minutes on it after the SC let go. If you did then look forward to replacing the front oil pump components and probably the housing too. Also, you will need to remove the engine and PTO housing for inspection of the rear oil pump.

  3. #3
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852

  4. #4
    MikeB's Avatar
    Join Date
    Jan 2007
    Location
    Orlando, FL
    Posts
    278
    Dammit, didnt want to hear that.

    Oh well its raing so I have some free time.

  5. #5
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    What year is your ski and how many hours?

  6. #6
    Flynfox's Avatar
    Join Date
    Aug 2006
    Location
    Sunny SC
    Posts
    682
    Sorry to hear that man. I know from reading your posts you have not enjoyed much time on your new ski.

    Good Luck,

  7. #7
    MikeB's Avatar
    Join Date
    Jan 2007
    Location
    Orlando, FL
    Posts
    278
    It's a 05 RXP. I bought it with 33 hours on it. Currently it has 52.4, I rather do enjoy the time I spend on it. I had 1 mishap prior to this but it was unavoidable by sucking up a small stick, that was a 5 min fix and I was back on the water.

    I wish I didn't put the clutch washers off so long, so I put the blame on myself.

  8. #8
    that blows, sorry to hear that! how much time did you put on it when you noticed only 6XXX rpms?...PR...

  9. #9
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    Quote Originally Posted by MikeB View Post
    FYI, the ski was only in the water for less than 10 minutes.

  10. #10
    FIRED!!! JP's Avatar
    Join Date
    Dec 2006
    Location
    Fort Lauderdale, FLORIDA baby...
    Posts
    3,505
    Quote Originally Posted by MikeB View Post
    I went out to the river today and noticed somehting was wrong right off the bat since I didn't hear the SC like usual. Im guessing that the washers are shot. Funny thing is last time I had the ski out it was running just fine, no problems and no hint of a loss of power. FYI, the ski was only in the water for less than 10 minutes.

    Everyone say a prayer for me not to tear apart this engine.
    Good Luck Mike, even though 6400 has always seemed to be the 'poison' number, this is EXACTLY what happend to me, I think Jerry's prediction may be right...

    Let us know...

    JP

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 SLX 780 RPM stuck at 3550???
    By okcgravity in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-19-2012, 04:26 PM
  2. gp1300 stuck at 5000 rpm
    By Binihana in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-25-2011, 06:11 AM
  3. 05 RXp stuck at 7500 rpm
    By Boosted3s in forum 4-Tec Performance
    Replies: 41
    Last Post: 06-23-2011, 09:54 AM
  4. Stuck at 6000 RPM's
    By Aldoe in forum Yamaha How To & FAQs
    Replies: 2
    Last Post: 05-29-2010, 05:46 PM
  5. Stuck at 8,000 RPM"S. ??????????
    By 4-techscharger in forum 4-Tec Performance
    Replies: 64
    Last Post: 07-08-2007, 02:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •