Results 1 to 10 of 10
  1. #1

    Kawasaki Ultra 260X - Impeller help

    Hi guys,

    I have written on this forum last year concerning a speed problem with my Kawi. Again, I bought a 2009 Ultra 260X with 21 hours on it (now 40 hours) and the watercraft was mint ! I started riding the thing but I was very dissapointed because I hardly hit 50 mph (flat and rough water) and a lot of people on the net said they could bring it up to 65-70 mph.

    Some guys answered and told me to check the plug and the oil wich I did but I wasnt sure that they would affect the speed of 20 mph. At some point, I though that the FPO key wasnt programmed properly so I ordered a brand new one from Kawasaki but no change at all. Finally, some people were also saying that my supercharger was leaking so before using it this year, i brought it at the Kawasaki dealer to have maintenance done and asked them to verify the supercharger for leaks. Everything was fine (oil changed, plugs changed, no leaks, new key) but again, NO SPEED GAINS.

    Now the last thing, THE IMPELLER ... Kind of pisses me off to figure out that the impeller is that much damaged after only 40 hours. The other day, i found a big rock in the back of the turbine (1 inch diameter). This sure didnt help it but i wasnt going faster even before i got through.

    So now, I am planning on putting a brand new impeller in there. The original Kawasaki impeller costs 635.00 $ wich is too much so i would like to put a good aftermarket impeller in there. I looked at solas on the web and they seem to have a pretty good impeller for my watercraft wich is not to expensive !

    WHAT WOULD YOU GUYS RECOMMEND ? What brand ? Type of impeller ? Same pitch as stock (15/23) ?

    I definitely want that top speed !

    Thanks


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    can i ask have you used a gps to confirm your speed? what are your WOT RPMS read them on the fly not the stored!! if you are using the stock dash for your speed that could be your problem. sounds to me the paddle wheel might be damaged or not lowered to the correct height. we always found the stock prop to be best, if you are in the states send the pump to impros to get the prop matched and repaired to the liner.

  3. #3
    deepwest563's Avatar
    Join Date
    Jan 2011
    Location
    Davenport, Iowa
    Posts
    78
    +1
    9
    Last year, I installed a Solas impeller. I hated it. the top speed was ok but when I squeezed the throttle, I had nasty cavitation and prop spin. It went "ni ni ni ni ni ni ni ni" before finally hooking up and taking off (in my 2-stroke dirt bike voice) I dug out my stock impeller and put it back on. I'm going to ride Friday night to see if that fixed the problem. I seen a bran new OEM impeller on ebay for under $400

  4. #4

    Join Date
    May 2008
    Location
    Sweetwater
    Posts
    887
    +1
    139
    IMPROS will also fix the stock impeller for a lot less than even the used one. They do awesome work..

  5. #5
    Thanks for the replies.

    First of all, it wasn't a GPS reading and I know that the one on the watercraft isnt so accurate but my friend with is GTX260is claims that his top speed is 70 mph and when we go riding together, forget it, he is far ahead...

    Concerning IMPROS, i don't live in the states, I live in quebec and since the summers are short here and not always nice... i don't want to be sending the whole pump for a month and have the watercraft benched in the garage.

    So again, what impeller would you recommend ! And deepwest563, I am not sure to understand your two stroke language thing haha ... but if you could detail a little more because i might get a solas from eBay since i cant find the oem used one !

    thanks again

  6. #6
    deepwest563's Avatar
    Join Date
    Jan 2011
    Location
    Davenport, Iowa
    Posts
    78
    +1
    9
    Shit... if you want my Solas impeller, you can have it.

  7. #7
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Dont get the solas

  8. #8
    Whats the issue with the solas impella? What is the preferred replacement, any particular reason?

  9. #9
    I did tons of impeller testing with the 250X........I even have an very long post on it somewhere in here.....

    Solas 16/21 was the very best out of 6 impellers i tested.

    dave

  10. #10
    Cool.. thanks for the information. In the process of trying to locate one now. Cheers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 Kawasaki Ultra 260X shuts off if rpm goes over 2000. - Please help
    By serge9193 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 20
    Last Post: 06-20-2012, 12:50 PM
  2. Need Help Please - 2009 Kawasaki Ultra 260x - Seized Supercharger
    By MountainMan in forum Kawasaki Open Discussion
    Replies: 7
    Last Post: 06-07-2012, 10:01 AM
  3. FS Kawasaki Ultra 150 Impeller For Sale / New SBT
    By kaboom3757 in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 09-09-2010, 09:06 AM
  4. Warranty question. kawasaki ultra 260x
    By pottzr in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 06-17-2010, 05:37 PM
  5. i want my kawasaki ultra 260x be 75 mph
    By JsH in forum Kawasaki PWC Performance (4-stroke)
    Replies: 17
    Last Post: 05-11-2009, 11:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •