Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Aug 2008
    Location
    Eastern NC
    Posts
    223
    +1
    8

    2003 GTX DI Miss

    Just finished a rebuild. Engine idled with a miss. No maint light. Hooked up a timing light to each wire. Mag was fine, PTO had a miss in the fire.

    I swapped plugs and the miss followed the plug. Changed the plug out with another old one that I bead blasted.

    No miss on either, but it still sounds like it has a miss and revs with the throttle, but not smoothly. Going to put brand new plugs in it tomorrow. Anything else to check?

    Plugs are coming out sooty on the tips.

    I know I want to see fuel pressure, but how do I connect a gauge? Do I just cut into the hose and splice in a tee with gauge?


  2. #2

    Join Date
    Aug 2008
    Location
    Eastern NC
    Posts
    223
    +1
    8
    Well, I think I figured out how to find my problem. Rented a fuel test gauge from the auto store, and ordered candoo after going back and forth between it and buds. Now the wait for the hardware starts. Already received the tracking #, so now I am living in front of my laptop hitting the refresh button.

    While I wait I am downloading the drivers and software. 2 questions though.

    I am going to install it on my company laptop, but IT has already said they are going to swap out my laptop within the next month. Will I have any issues moving my software license over?

    I know that the home license comes with 4 vins. I know you can buy more, up to 15. I know you can pay a fee to upgrade to unlimited. Now I bought the home. Say I buy vins up to the 15 limit, then decide to upgrade. Do I get any credit for all those vins I bought, or do I just eat that cost and pony up the $1400 upgrade fee? Seems that getting vin credit would be a great way to work up to buying the unlimited version.

  3. #3

    Join Date
    Mar 2006
    Posts
    1,829
    +1
    119
    I think you eat the 15.

  4. #4
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    Re-check the wiring connections at the coils for corrosion in the rear box. You can also ohms test the coils.

  5. #5
    actis's Avatar
    Join Date
    Mar 2013
    Location
    maryland and florida
    Posts
    142
    +1
    5
    You might want to check but I believe the unlimited licences fee is annual. I maybe wrong.
    only speaking of the UNLIMITED.

  6. #6

    Join Date
    Aug 2008
    Location
    Eastern NC
    Posts
    223
    +1
    8
    The $1400 is a one time and there is a annual fee for both home and unlimited if you want to stay updated. Like $39 for home and $169 for unlimited.

  7. #7

    Join Date
    Aug 2008
    Location
    Eastern NC
    Posts
    223
    +1
    8
    Ok, got candoo and loving it. It is rather slow to respond to button presses and such, but it works and does the job. I hooked up and was getting a low and very low batt code. Cleared codes. Pulled and charged batt to full. Let sit 24 hrs then checked. Charger said it was back to 70%. Charger at 2 amp back to 100% then put it in the ski. 2 new ngk spec plugs properly gapped, and hooked up candoo and started the ski. Voltage on the batt was 12.6 and never went any higher during running. It dipped to 11.4 of so as the rpm was increased. Got another low batt code. Going to order a new batt and voltage reg. Is the greenhulk store going to be my best bet for these? I know some people mention a more robust voltage reg is available.

  8. #8

    Join Date
    Aug 2008
    Location
    Eastern NC
    Posts
    223
    +1
    8
    Ok. Just called the local dealer about a voltage reg. said they would cut me a deal for $150. I feel special.

  9. #9

    Join Date
    Aug 2008
    Location
    Eastern NC
    Posts
    223
    +1
    8
    Here are the screen shots if anyone is interested.Click image for larger version. 

Name:	30sec.png 
Views:	27 
Size:	14.7 KB 
ID:	334105Click image for larger version. 

Name:	Codes.png 
Views:	26 
Size:	37.1 KB 
ID:	334106Click image for larger version. 

Name:	MinMax.png 
Views:	33 
Size:	15.0 KB 
ID:	334107

  10. #10
    Check the coils in the back of your ski, we had that problem and figured it out by swapping coils from another machine and other machine then had problem so we knew that was it.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 GTX di Stalled on water wont start
    By Big Kid in forum 2-Stroke Performance
    Replies: 5
    Last Post: 08-17-2010, 08:14 AM
  2. 2003 gtx di with trailer
    By 20rxp04 in forum Sea Doo 4Tec Skis
    Replies: 13
    Last Post: 05-28-2009, 09:05 AM
  3. 2003 gtx di maintenance mesge, how to remove???
    By rsalvarez in forum 2-Stroke Performance
    Replies: 1
    Last Post: 04-02-2009, 06:38 AM
  4. 2003 GTX DI fuel pump
    By XtRmn8 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 11-16-2008, 06:52 PM
  5. wtb seatcover for 2003 gtx di
    By sic fish in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 08-23-2008, 07:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •