Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    redchev67's Avatar
    Join Date
    Apr 2012
    Location
    South Jersey
    Posts
    47
    +1
    2

    07 rxp 215 symptom and problem

    Was riding in the ocean today and a sand bar came up, luckily I was looking out for shallow spots anyway because the tide was low..so the ski was in about 2 ft of water when I hit it. I quickly shut it down. I pushed it off and turned back around. When I restarted the ski I could hear and feel a difference also at full throttle I was only going 45 mph.. I got off and felt around the intake grate to make sure I didn't suck anything up and I didn't but I felt a ring on the prop just hanging there.. can anyone tell me what I'm dealing with? Thanks
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20140615_192629.jpg 
Views:	69 
Size:	59.7 KB 
ID:	332787  


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Thats is your problem...take the pump off and pull that ring out/off and then take off the rubber boot attached to the front of your prop off too...If you dont take the boot off then you will experiance the same thing next time you go out riding..You can try to put that ring back on boot BUT it will come off again...IF your addiment about running a nose cone then see if anybody has a solas laying around they want to part with,,this way you can at least loctite it to the prop....

  3. #3
    redchev67's Avatar
    Join Date
    Apr 2012
    Location
    South Jersey
    Posts
    47
    +1
    2
    Thank you snoman, so that ring is supposed to be attached to the boot? Or underneath off it? also if you don't mind explaining to me how that affected my skis mph?

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    That ring is used to keep pressure on the front/top of the nose cone to the driveshaft therefor not allowing water into the prop spines and supposedly directing the water into the prop hub....This will affect your speed because if i am correct you gas your ski and she sits there wanting to go but goes nowere..this is causeing air in your pump area called cavatation....this is bad in a jet pump setup...you want no desturbances in this area, you want this area as efficiant as possible so it moves the volumn of water through there efficiantly and with no desturbance.....otherwise if you have any thing that is out of line,you will have/get cavatation causeing a lose of speed and power through the pump

  5. #5
    redchev67's Avatar
    Join Date
    Apr 2012
    Location
    South Jersey
    Posts
    47
    +1
    2
    Thank you very much snoman

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Anytime buddy

  7. #7
    redchev67's Avatar
    Join Date
    Apr 2012
    Location
    South Jersey
    Posts
    47
    +1
    2
    So if you could just answer one more question for me please..can I simply remove the boot and ring and ride without it, or is it essential? And if I can't do that, I guess I will have to go with the solas but even with the solas will it use that ring?

  8. #8
    want2bem3's Avatar
    Join Date
    Sep 2013
    Location
    Philly PA
    Posts
    39
    +1
    3
    I had the same thing happen on my 04, it didn't affect the performance of the ski, I only found it was there when I swapped out my intake grate.

  9. #9
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Yes you can ride without it...it will not hurt anything,just make sure you flush that area after riding thats all..

  10. #10
    redchev67's Avatar
    Join Date
    Apr 2012
    Location
    South Jersey
    Posts
    47
    +1
    2
    Thats good hear...thanks again

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 07 RXP 215 Black and Yellow
    By ar101588 in forum Sea Doo 4Tec Skis
    Replies: 4
    Last Post: 09-23-2016, 04:58 PM
  2. FS - Parts 07 rxp 215 engine block and other parts
    By XP537 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 11-21-2012, 03:35 PM
  3. Buying an 04-07 RXP 215 SC
    By matrixman16 in forum Sea Doo Open Discussion
    Replies: 22
    Last Post: 04-30-2009, 09:18 AM
  4. WTB: 07 RXP white hood and parts.
    By Water4fire in forum Sea Doo Classifieds
    Replies: 8
    Last Post: 09-28-2008, 06:07 PM
  5. FS - 07 RXP 215, Kaw 250X, W/ trailer
    By tckylem in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 08-21-2008, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •