Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 36
  1. #1
    Plrs X45's Avatar
    Join Date
    Sep 2006
    Location
    Joliet, Il
    Posts
    357
    +1
    5

    Help! I need service for Polaris Watercraft in Chicagoland area!

    Can anyone help me? I have issues with Genesis FFI and I need it fixed before 4th of July. Is there anyone in the Chicagoland area that still fixes Polaris Watercraft? Anything close to Joliet, IL would be great.


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    What are the issues? Maybe we can help.

  3. #3
    Plrs X45's Avatar
    Join Date
    Sep 2006
    Location
    Joliet, Il
    Posts
    357
    +1
    5
    Well, My X45 has no issues. I would just like someone to go over it to make sure it's running good. The Genesis FFI, however, is a different issue. At first startup, it cuts in and out until it warms up. This maybe only for a few minutes. Once it's warm, there are no issues. At the end of the season however, it started taking a little longer. When I say cutting in and out, I mean that it feels like it is hitting the rev limiter. This is at very low rpm's (like 2k). Thanks for any that can assist in this matter.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by Plrs X45 View Post
    ... Genesis FFI, however, is a different issue.

    At first startup, it cuts in and out until it warms up. This maybe only for a few minutes. Once it's warm, there are no issues. At the end of the season however, it started taking a little longer.

    When I say cutting in and out, I mean that it feels like it is hitting the rev limiter. This is at very low rpm's (like 2k). Thanks for any that can assist in this matter.
    Are you interested in doing some diagnostics?

  5. #5
    Plrs X45's Avatar
    Join Date
    Sep 2006
    Location
    Joliet, Il
    Posts
    357
    +1
    5
    what do I need to do? Thanks in advance.

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I had that issue with my MSX and it turned out to be a fuel pressure issue

  7. #7
    Plrs X45's Avatar
    Join Date
    Sep 2006
    Location
    Joliet, Il
    Posts
    357
    +1
    5
    Any other ideas?

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by Plrs X45 View Post
    what do I need to do? ...
    Lets begin by removing the LR-503 Start/Stop module. That will eliminate possible interference from a failing LR module.

    Has the TPS sensor been replaced? Do you have a spare?

  9. #9
    Plrs X45's Avatar
    Join Date
    Sep 2006
    Location
    Joliet, Il
    Posts
    357
    +1
    5
    The TPS has never been replaced. Where can I get one and is it difficult?

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by Plrs X45 View Post
    The TPS has never been replaced. Where can I get one and is it difficult?
    TPS is available from any of the Polaris OEM parts sources.

    Installation is quite easy. Just need an 8mm box end wrench for the three small TPS bolts. I just changed one this morning.

    If your Genesis is from before 2002 you will need to slightly modify the throttle body shaft end. Not difficult, just fiddly. Can be done with everything in place but is easier if the flame arrestor assembly is removed, since it extends over the TPS work area.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Interest in dyno service for polaris engines
    By 2&4strokepolaristech in forum Polaris Open Discussion
    Replies: 19
    Last Post: 11-10-2010, 08:12 AM
  2. Polaris Service in Chicagoland Area?
    By abodner in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-20-2010, 09:47 PM
  3. Service for ultra 250 in houston???
    By rworthington in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 07-02-2009, 07:20 PM
  4. need parts for polaris slx780 1995
    By andy95'slx780 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 02-10-2008, 11:42 AM
  5. Need info for Polaris 785
    By JBX in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 05-18-2007, 09:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •