Results 1 to 7 of 7
  1. #1

    Desperate Need for Sender,FUEL SENDER Pt# (2410173) 2001 POLARIS PRO 1200

    If anyone could help me out it would be greatly appreciated. I need a replacement fuel sender for my 2001 polaris pro. I have tried every store on the internet, literally eevry store, no one has it in stock it will take 6 days on average to come from Polaris to the dealership who would than send it to me at that same time frame. Im looking at two weeks out of the water for a stupid fuel pump. Can anyone point me in the direction of a dealer who ships same day and keeps items like this in stock, or does anyone have a used working one of these that i could buy from you? Thank you in advance

    Also if anyone knows of any PWC mechanics in the Philadelphia area could you hook me up with a refrence


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Whats wrong with your sender/fuel pick up?

  3. #3
    Quote Originally Posted by BryanP View Post
    Whats wrong with your sender/fuel pick up?
    Its not sucking gas. Wave runner is bogging out, full throttle I'm going 3 mph, and randomly the bike will kick like its gonna jump out the water then just bogs out again. I can ride idle no problem but can't hold any kind of normal speed at all. Plugs are new, lines are clean, carbs are clean, air filter is new, and the bike starts up first time in or out of water perfectly with zero hesitation. I'm just assuming this has to be my problem, its the one main component that's in charge of giving the engine gas, and when ever I ask it to its def not. I've driven a ton of different machines and this is def a fuel problem. Engine is not getting gas, even if its not the sender

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I don't see how the sender could be bad. Its just an aluminum tube. I would check the fuel shut off valve and the water separator. See if there is any kind of flow restriction there. Check your pulse lines. An issue there could cause the fuel pumps to not pump properly. Have you checked the accel pump on the carbs? Does it squirt furl when you pull the throttle. When you were inside the carbs did you check the arm height?

    Have you checked engine compression?

  5. #5
    blairwill4's Avatar
    Join Date
    Apr 2014
    Location
    Fort Wayne IN
    Posts
    339
    +1
    1
    I agree with bryan; the fuel sender is just a glorified gas straw. It sounds to me like there are other issues here. I know it was AROUND the year 2001 when tempo lines stopped going in skis. Make sure your lines arent grey, and if you've been around a lot of skis you'll know how to check the carbs and everything that Bryan listed above.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by jasonstackhouse View Post
    ... is bogging out, full throttle I'm going 3 mph, and randomly the bike will kick like its gonna jump out the water then just bogs out again. I can ride idle no problem but can't hold any kind of normal speed at all.

    Plugs are new, lines are clean, carbs are clean, air filter is new, and the bike starts up first time in or out of water perfectly with zero hesitation...
    What is it doing when you squeeze the throttle?

    On the trailer does it rev easily to redline?

    In water when you ask for power does it rev up but no thrust?

    Or not rev up much at all? Does it run rough when throttle is applied, missing, hesitating or surging?

    Any chance there is a flow restriction in the exhaust system? Overheated exhaust hose can delaminate internally and bulge inwards inside the hose.

  7. #7
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I would also check to make sure the fuel lines are connected to the correct places on the pickup. Its really easy to mix them up. Don't ask me how i know that.....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 polaris genesis 1200 fuel injected
    By J4ke1990 in forum Polaris PWC Performance
    Replies: 24
    Last Post: 05-27-2014, 08:26 AM
  2. Polaris pro 1200 problem need help!!!
    By polaris pro 1200 mods in forum Polaris PWC Performance
    Replies: 7
    Last Post: 05-30-2013, 06:16 PM
  3. WTB WTB - Looking for cross over exhaust hose. Polaris Pro 1200
    By 1998PRO785HO in forum Polaris Classifieds
    Replies: 0
    Last Post: 07-12-2011, 01:42 PM
  4. FS TDR waterbox For polaris pro 1200
    By Vagaondracing103 in forum Polaris Classifieds
    Replies: 0
    Last Post: 12-08-2008, 01:42 PM
  5. WTB: Polaris Pro 1200 PTS [email protected]@K
    By mr.candid in forum Polaris Classifieds
    Replies: 7
    Last Post: 07-12-2008, 01:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •