Results 1 to 7 of 7
  1. #1

    WTF?...top speed loss after upgrading exhaust on gp1300r

    So I have an 04' gp13r as my second ski (ultra 250x main ski... much better and faster ski)... Last year the gp13r with just a riva ride plate and intake grate had a gps top speed of 66.8mph. Over the winter I replaced the factory waterbox with a gp1200r waterbox and put a riva free flow on the ski. Now my gps top speed is only 63.8mph...WTF? Anyone have any ideas why?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Same outside air temperature during both tests?

  3. #3
    yes... same air temp... i was figuring i may gain 1mph, not lose 3mph

  4. #4
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    535
    Quote Originally Posted by slpgt02 View Post
    So I have an 04' gp13r as my second ski (ultra 250x main ski... much better and faster ski)... Last year the gp13r with just a riva ride plate and intake grate had a gps top speed of 66.8mph. Over the winter I replaced the factory waterbox with a gp1200r waterbox and put a riva free flow on the ski. Now my gps top speed is only 63.8mph...WTF? Anyone have any ideas why?
    yep 1200 water box less back pressure, free flow less back pressure you will lose speed.

  5. #5
    Thanks i was thinking that...If I put factory waterbox back on will I get all speed back or just some?

  6. #6
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    535
    Quote Originally Posted by slpgt02 View Post
    Thanks i was thinking that...If I put factory waterbox back on will I get all speed back or just some?
    Just some. The only time i like using a free flow on a 2 stroke is when i mod the ski and add more compression.

  7. #7
    Prism's Avatar
    Join Date
    May 2007
    Location
    "New" Jersey
    Posts
    826
    +1
    99
    Quote Originally Posted by slpgt02 View Post
    Over the winter I replaced the factory waterbox with a gp1200r waterbox and put a riva free flow on the ski. Now my gps top speed is only 63.8mph...WTF? Anyone have any ideas why?
    Its my understanding and experience that the free flow tube costs some rpm and speed up top. It is used by highly modified skis (like Jim just metioned above or more modified) to prevent detonation damage. In these skis, the 1200 box creates a sonic reflection that matches what the modified engine needs for higher top end. At that point the loss from the free flow and the gain from the better matched waterbox offset and the skis engine stays together. On mildly modified skis the stock sound suppression and 1200 box are a gain. .02
    Last edited by Prism; 06-19-2014 at 11:19 PM. Reason: spelling

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Top speed loss on 14 fx crusiser svho: you make the call
    By scott2640 in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 06-04-2016, 06:27 PM
  2. Worx intake grate on my 2015 STX-15F top speed loss
    By grhendo308 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 08-16-2015, 06:05 AM
  3. Wake 155 rpm and speed loss after new impeller and wear ring
    By 07seadoowake155 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-30-2013, 09:40 PM
  4. Replies: 0
    Last Post: 05-11-2009, 01:29 AM
  5. RPM/Speed loss after new pump bearings.
    By OutlawGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-06-2008, 09:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •