Results 1 to 4 of 4
  1. #1

    Problem installing impeller shaft/bolts in hull stripped HELP please

    I was Resealing the impeller shaft/intermediate bearing housing on my vx cruiser but upon taking it out the 3 screws going into the hull pulled the material with them and now when installing new housing I cannot tighten the 3 8mm screws they just spin in the hull what do I do now???

  2. #2
    Can I fill the holes with something like marine tex then drill and tap new threads ?

  3. #3
    1200 stx-r's Avatar
    Join Date
    Jul 2007
    Try to clean and tap to the next size or get helicoils....and dont be so rough...they are just little bolts...

  4. #4
    I did not even put a socket on them they just fell into the holes when I removed them the fiberglass or whatever the material is came out with the screws

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pump shaft won't come out! help please!
    By martynwilley in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 12-22-2013, 11:21 AM
  2. Problem installing impeller - Need measurement!
    By kman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 05-08-2010, 09:30 AM
  3. Installing impeller... at work and need ASAP help
    By 240witSR in forum 2-Stroke Performance
    Replies: 12
    Last Post: 06-12-2008, 08:07 AM
  4. Having problems starting my 900 STX after carb cleaning, HELP PLEASE???
    By Bala in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-10-2008, 06:03 PM
  5. Will Virage drive shafts and impellers work on 750 hull from 94?
    By JGringo in forum Polaris Open Discussion
    Replies: 14
    Last Post: 08-18-2007, 12:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts