Results 1 to 4 of 4
  1. #1

    Problem installing impeller shaft/bolts in hull stripped HELP please

    I was Resealing the impeller shaft/intermediate bearing housing on my vx cruiser but upon taking it out the 3 screws going into the hull pulled the material with them and now when installing new housing I cannot tighten the 3 8mm screws they just spin in the hull what do I do now???


  2. #2
    Can I fill the holes with something like marine tex then drill and tap new threads ?

  3. #3
    1200 stx-r's Avatar
    Join Date
    Jul 2007
    Location
    NWCT
    Posts
    2,517
    +1
    200
    Try to clean and tap to the next size or get helicoils....and dont be so rough...they are just little bolts...

  4. #4
    I did not even put a socket on them they just fell into the holes when I removed them the fiberglass or whatever the material is came out with the screws

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water in hull after rebuild-Please Help!!!
    By tejhummer in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 09-28-2014, 08:42 PM
  2. Flywheel bolts, in hull or pull engine ?
    By canuck in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-05-2014, 12:58 AM
  3. Problem installing impeller - Need measurement!
    By kman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 05-08-2010, 09:30 AM
  4. Installing impeller... at work and need ASAP help
    By 240witSR in forum 2-Stroke Performance
    Replies: 12
    Last Post: 06-12-2008, 08:07 AM
  5. Need to Find Rocker Arm Shaft Bolts IN STOCK
    By sr71bb in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-19-2006, 03:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •