Results 1 to 3 of 3
  1. #1

    pump slipping and weird check engine light??

    So now we took it out and tried it out. It ran fine except right off the bat the check engine light came on (at about 3k rpm) but the ski kept running fine.

    We then ran it for about a mile and all of a sudden it felt like a car kicking out of gear and the ski would have a vibration and not engage the pump as normal. When I reved it up it would just have a high pitch whine. I removed/installed the key and started it back up and the ski acted normal until I got to about 5k rpms when it did the same thing again and 'kicked' out of gear and felt like it was slipping.

    Nothing has changed since the last time except I changed the oil and checked the level prior to taking it out. I don't know if it matters but it is at the upper level of the dipstick (slightly over the upper level). Should I take some out? I don't know how picky a super charger is if the oil is too high.

    The only codes that I read were the P0600 and P1607.


  2. #2
    speedjunky787's Avatar
    Join Date
    Jun 2014
    Location
    Florida
    Posts
    81
    +1
    5
    Quote Originally Posted by jglantz78 View Post
    So now we took it out and tried it out. It ran fine except right off the bat the check engine light came on (at about 3k rpm) but the ski kept running fine.

    We then ran it for about a mile and all of a sudden it felt like a car kicking out of gear and the ski would have a vibration and not engage the pump as normal. When I reved it up it would just have a high pitch whine. I removed/installed the key and started it back up and the ski acted normal until I got to about 5k rpms when it did the same thing again and 'kicked' out of gear and felt like it was slipping.

    Nothing has changed since the last time except I changed the oil and checked the level prior to taking it out. I don't know if it matters but it is at the upper level of the dipstick (slightly over the upper level). Should I take some out? I don't know how picky a super charger is if the oil is too high.

    The only codes that I read were the P0600 and P1607.
    The cavitation dont have nothing to do with the SC or oil. However your oil level should be half way the dipstick if you have too much oil what youll see is that your ski will be low on revs. The cavitation you have is either a problem with the pump, shaft .... I would start by pulling the pump out and inspecting then the shaft.

  3. #3
    Quote Originally Posted by speedjunky787 View Post
    Quote Originally Posted by jglantz78 View Post
    So now we took it out and tried it out. It ran fine except right off the bat the check engine light came on (at about 3k rpm) but the ski kept running fine.

    We then ran it for about a mile and all of a sudden it felt like a car kicking out of gear and the ski would have a vibration and not engage the pump as normal. When I reved it up it would just have a high pitch whine. I removed/installed the key and started it back up and the ski acted normal until I got to about 5k rpms when it did the same thing again and 'kicked' out of gear and felt like it was slipping.

    Nothing has changed since the last time except I changed the oil and checked the level prior to taking it out. I don't know if it matters but it is at the upper level of the dipstick (slightly over the upper level). Should I take some out? I don't know how picky a super charger is if the oil is too high.

    The only codes that I read were the P0600 and P1607.
    The cavitation dont have nothing to do with the SC or oil. However your oil level should be half way the dipstick if you have too much oil what youll see is that your ski will be low on revs. The cavitation you have is either a problem with the pump, shaft .... I would start by pulling the pump out and inspecting then the shaft.


    other day my pump bearings went out and I had a decent vibration and check oil light on when I put in a couple of times fine the rest of the day I would check to make sure your driveshaft hasn't moved forward sounds like a stripped driveline replaced pump bearings runs perfect now no oil warnings if you did strip driveline possible thrust bearing damage

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Out for a ride...Check engine light and codes..
    By Urwheelman in forum 4-Tec Performance
    Replies: 12
    Last Post: 08-29-2012, 09:40 PM
  2. 2002 Genesis i Check Engine Light and low RPM
    By waterhead in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 06-28-2011, 08:14 AM
  3. Check Engine light and performance issues Rxp Stage 3
    By trofodotiki in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-03-2011, 03:32 PM
  4. check engine light and error code P0351
    By cawky in forum 4-Tec Performance
    Replies: 16
    Last Post: 03-27-2009, 09:21 PM
  5. Check engine light and msg but no codE?
    By camar0 in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-15-2008, 03:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •