Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Anyone ever get a message on their Vtech "MAPTUNER LOCKED"??

    Last year my buddy bought a Vtech maptuner and we followed the steps to tune his 2012 RXTX... After recognizing the VIN for the ski and downloading updates, it says "MAPTUNER LOCKED" and can't get it to do anything. We got a hold of someone on the phone at Vtech and they got it fixed and his ski ran great.

    Now fast forward to this year... I bought a tuning credit to use on my new to me 2012 RXT 260... connected the maptuner, got the ski info (VIN) on the maptuner, got my license key submitted, went to check for updates and I got an error. And the maptuner device once again says "MAPTUNER LOCKED". This is so frustrating... I wish someone could tell me if there's something I'm doing wrong. Last night, Vtech support told me they couldn't see anything wrong with my account and sent a new license key. But tonight I couldn't even get far enough to use the new license key. It won't do anything except state "MAPTUNER LOCKED".

    I love the tune, but this issue needs to be resolved... I don't want to go through this every time I tune a ski!


  2. #2
    It can be a old firmware in your maptuner causing problems. Send it to us for an update

  3. #3
    Matatan tocullo's Avatar
    Join Date
    Nov 2010
    Location
    VISTA AL RIO FL
    Posts
    1,725
    +1
    69
    Last time i had that problem Jonatan had to go in to my computer remotely using a program call team viewer. However Jerry had to call him and give him some love first! Download that program and send him an email or call him so he can go onto your PC and fix it!!

  4. #4
    Matatan tocullo's Avatar
    Join Date
    Nov 2010
    Location
    VISTA AL RIO FL
    Posts
    1,725
    +1
    69
    Quote Originally Posted by VTECH.SE View Post
    It can be a old firmware in your maptuner causing problems. Send it to us for an update

    Work the magic i have no doubt you can do it!!

  5. #5
    Quote Originally Posted by VTECH.SE View Post
    It can be a old firmware in your maptuner causing problems. Send it to us for an update
    When this happened last year, you (Jonatan) were able to get it figured out from your end over the phone... I really need for someone to try this again because I don't have much time before a trip. Please help.

  6. #6
    Just sent email to Michel and Jonatan. Still not working and need my ski running as soon as possible. Here's s video:

  7. #7
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    They can unlock the maptuner remotely... Did you tried to connect it to another ski?

    It did the same a couple month ago and Jonatan unlocked it in 2 mins... Try to SMS vtech

  8. #8
    Jonatan fixed it last year but have been working with Michel this time. Still no luck after a bunch of testing yesterday. They will try again Monday... Ugh.

  9. #9
    Day #5 of trying the Vtech maptuner and still no luck. My lake trip date is getting VERY close and my ski is going to be FUBAR.

    Does anyone in the southeast have a Vtech tuner I can borrow for a fee? I have got to get this going...

  10. #10
    speedjunky787's Avatar
    Join Date
    Jun 2014
    Location
    Florida
    Posts
    81
    +1
    5
    Quote Originally Posted by boostedgta View Post
    Day #5 of trying the Vtech maptuner and still no luck. My lake trip date is getting VERY close and my ski is going to be FUBAR.

    Does anyone in the southeast have a Vtech tuner I can borrow for a fee? I have got to get this going...
    This is the shit that kills me about Vtech!!! Such a great product... but the costumer support is damn slow. Someone here in the US needs to take over there costumer support so we can get faster support.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anyone else get real attached to their ski?
    By KirkF350 in forum Yamaha Open Discussion
    Replies: 23
    Last Post: 02-14-2010, 01:23 PM
  2. Anyone driven to island racing on their waverunner?
    By official_style in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 08-07-2009, 08:31 PM
  3. anyone running red top carbs on their 787?
    By Joe Stang in forum 2-Stroke Performance
    Replies: 6
    Last Post: 05-13-2009, 01:13 PM
  4. Replies: 10
    Last Post: 01-11-2009, 10:46 AM
  5. Has anyone hooked up a horn on their sportster?
    By holdnon72 in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 05-17-2007, 04:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •