Results 1 to 8 of 8
  1. #1

    Join Date
    May 2014
    Location
    Arlington tx
    Posts
    59

    Ok wth I'd wrong lol. Polaris sl 780

    My sl 780 was running great after carb clean new piston fuel lines ect. Two times now runs great out of water hits rev limiter no problem but in water only run like 35 mph and turns around 5000 rms. compression 120 120 120 carbs seem to be getting gas cause when I rev it on trailer see it spraying. Cylinders all pretty close to same temp disconnect mfd totally no change All cylinders are firing cause I can get it to run on each single cylinder. Only thing I can think go is carbs need kits? Don't see leaks anywhere Stator ? Coils? Cdi? Would think if that was it would not run each individually. Could be wrong thou. Acts like it's just not getting fuel. Plugs brand new so can't really tell so wanted to ask the Polaris experts thanks in advance


  2. #2

    Join Date
    May 2014
    Location
    Arlington tx
    Posts
    59
    Great power on low end jumps right out if water and pushes truck when in water on trailer on ramp. Wear ring and prop look great very little clearence. From mid to high seems to be problem and high

  3. #3
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    853
    +1
    19
    Restrictor in?
    adding choke help or hurt?
    wash?

  4. #4

    Join Date
    May 2014
    Location
    Arlington tx
    Posts
    59
    Did not have a restrictor when I changed the lines. So no there is not one if you are talking about in return line. Did not try choke Wash best I can tell with light looks normal but did not tear down to make sure. I was thinking about trying a restrictor know it won't hurt. Why would it run fine thru two full tanks since doing lines carbs top end then not on 3rd tank if it was restrictor? Lol not saying it wouldn't thou I am not a Polaris guy usually. Defiantly acting carb related but nice again not used to Polaris ways yet Thanks for the reply thou

  5. #5
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I think the 780 carbs have the restrictor built in.

  6. #6

    Join Date
    May 2014
    Location
    Arlington tx
    Posts
    59
    Kinda funky idle even dying when it has never done that down on rpm and mph runs good on trailer lots of gas on bottom of carb cover good low end hard to start the first time. Everything firing and can see gas spraying each carb smoking little more then it was Think I am going to pull the reeds for a inspection

  7. #7

    Join Date
    May 2014
    Location
    Arlington tx
    Posts
    59
    Reeds look good guess I will start electrical testing.

  8. #8
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by BryanP View Post
    I think the 780 carbs have the restrictor built in.
    Yes they do, no external restrictor needed....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS Another Polaris SL 780 Partout
    By D007 in forum Polaris Classifieds
    Replies: 3
    Last Post: 12-22-2012, 09:14 PM
  2. 1996 Polaris sl 780
    By CSchipper in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-06-2011, 10:43 PM
  3. Hi new Polaris SL 780 user with lots of questions.
    By birdgod in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-09-2010, 06:18 PM
  4. Polaris Sl 780 rebuild and running hot on stator cyl.
    By gvnitup in forum Polaris Open Discussion
    Replies: 13
    Last Post: 08-12-2009, 09:36 PM
  5. lack of power on my polaris sl 780
    By polaris in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-19-2008, 03:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •