Results 1 to 6 of 6
  1. #1
    Tedcfitz's Avatar
    Join Date
    Jan 2012
    Location
    Dunn NC
    Posts
    176

    What is causing engine to skip?

    Please take a look at the 12 sec YOUTUBE video link of this problem. The engine will momentarily shut down or skip for no apparent reason. It does not happen every time I make a run, but it does happen often enough to be a problem.

    This is a conversion and the engine is a 2009 rxt 4-tec with 60 lb injectors, X charger, external intercooler, reflashed RIVA ECU, CDM fuel tuner.

    AFR's are good and I just re-installed the fuel map. I also installed a new AGM battery and filled with fresh gas.

    Has anyone experienced this?



  2. #2
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    Check coil packs make sure they aren't rusting and they are cleaned along with new spark plugs... I had mine do that same thing at same rpm .

  3. #3
    RXP 260 X Short Course Veteran RXP244's Avatar
    Join Date
    May 2007
    Location
    Auckland, New Zealand, New Zealand
    Posts
    1,244
    +1
    104
    Also check Plug Gaps and make sure they are not too big. Try closing them up to 20 thou.

  4. #4
    Tedcfitz's Avatar
    Join Date
    Jan 2012
    Location
    Dunn NC
    Posts
    176
    Will do, thanks!

    Quote Originally Posted by RXP244 View Post
    Also check Plug Gaps and make sure they are not too big. Try closing them up to 20 thou.

  5. #5
    Tedcfitz's Avatar
    Join Date
    Jan 2012
    Location
    Dunn NC
    Posts
    176
    I replaced the plugs. Here are the ones that came out. 2 were gapped at .028 and one was at .034 (too much!). I gapped the new ones at .026.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_20140621_113909.jpg 
Views:	50 
Size:	120.2 KB 
ID:	333293   Click image for larger version. 

Name:	IMG_20140621_113955r.jpg 
Views:	44 
Size:	130.6 KB 
ID:	333294  

  6. #6
    Tedcfitz's Avatar
    Join Date
    Jan 2012
    Location
    Dunn NC
    Posts
    176
    any other comments/help??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 10
    Last Post: 08-06-2014, 01:36 PM
  2. What is causing the engine to miss?
    By Tedcfitz in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-21-2014, 01:13 PM
  3. what would cause this to happen this is a good one!
    By Mike H in forum 4-Tec Performance
    Replies: 26
    Last Post: 10-04-2010, 11:19 PM
  4. So what is everyone up to tonite??
    By two2curupt in forum Sea Doo Open Discussion
    Replies: 29
    Last Post: 12-01-2005, 04:13 PM
  5. What is the trick to the IC block off plate???
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-09-2005, 08:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •