Results 1 to 6 of 6
  1. #1

    2008 Kawasaki Ultra 250X acceleration issue

    Here's a link to a video showing the exact same issue I'm having with my ski. I've seen several suggestions online from needing a new fuel pump, fuel screen cleaning, super charger belt, etc. It happens all the time, whether I just dropped in or whether I've been skiing a while. Once it gets up it will get going but still doesn't seem quite right. I basically have to halve throttle it to get a somewhat decent acceleration. I've checked the belt and it looks fine and I haven't seen any water inside to suggest slippage. Plugs, oil, oil filter, battery have been replaced recently. Any ideas or suggestions before I take it to a shop?



    Thanks


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,165
    +1
    602
    Supercharger belt tension , water in the hull comes to mind first

  3. #3
    Thanks for the reply.
    I'm positive it's not water in the hull because it happens as soon as I drop it in the water. I've checked after pulling it out and it's dry. I've checked the tension by hand and it seemed good but obviously not the best way. Any ideas or tricks to check the tension without getting the tool mentioned in the service manual?

  4. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    sounds like a boost leak to me, or belt slip as mentioned. a cheats way to tell is twist bottom section of belt it shouldnt twist any more than 1/4 twist, but tool is highly recommended.

  5. #5
    An update for anyone interested. It turns out the impellor was the problem. Apparently, sand getting shot through there caused problems with clearances and all that jazz. Got it replaced and now it runs like a champ.

  6. #6
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Wow good to hear I guess we never look at the prop causing that issue unless it is totally shot lol. Hard to believe some let them go that far

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 07 kawasaki ultra 250x WOT issue.
    By Lennox250ultraX in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 09-27-2011, 06:53 AM
  2. JETSKI JUNKIES - Testing 2008 Kawasaki Ultra 250X!!!
    By JETSKI JUNKIES in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 12-12-2010, 01:17 AM
  3. FS 2008 kawasaki ultra 250x super clean
    By SAL08HO in forum Kawasaki Skis
    Replies: 12
    Last Post: 07-12-2010, 07:58 PM
  4. FS 2008 Kawasaki Ultra 250x 4 sale ...MUST READ!!
    By PowerShot in forum Kawasaki Skis
    Replies: 7
    Last Post: 12-11-2009, 01:16 PM
  5. 2008 Kawasaki Ultra 250X Starting Issue
    By RNYE in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-25-2009, 10:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •