Results 1 to 2 of 2
  1. #1

    Join Date
    Jun 2014
    Location
    Knoxville,tn
    Posts
    3

    2004 15f low on power after pump swap

    I just purchased a 2004 15f with 170 hours. It just had the pump changed last week. It ran fine on test ride which was only 10 minutes. I purchased it brought it home and had it back on the lake within 2 hours of lake test. It started great idles through no wake zone fine which takes approx 10 minutes from trailer to end of no wake zone. So when I hit the throttle it took off but my son on our older 12f killed me out of the hole. It never would reach max rpm and kept losing rpm at WOT. I stopped and checked the intake but it was good. When I hit the starter it cranked really slow and then wouldn't crank at all. It gave an alarm and flashed battery. It has a brand new interstate battery that was purchased and installed today. After it sat for about 45 minutes it would crank and tried to start but I killed it before it started. Do you think something is wrong with the pump install or pump it's self? Any help would be great.

    Bill
    2003 stx 12f
    1989 650sx stand up
    1996 polaris 780 grafted into a 12ft jon boat.


  2. #2
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,409
    +1
    193
    As that was just changed
    It would be the first place I would look
    Pull it back out and see how free it is
    Could be a center bearing problem as well

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 sl900 low on power in water
    By jasonsmithftw in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-22-2015, 12:19 PM
  2. Low on power/mph
    By indosurf in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-22-2014, 01:23 PM
  3. 2004 XLT 1200 low on power
    By ramster in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-31-2012, 09:10 PM
  4. STX-R - low on power
    By toomanytoys in forum Kawasaki PWC Performance (2-stroke)
    Replies: 26
    Last Post: 08-01-2009, 05:51 PM
  5. Low on power
    By fullshift in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-21-2008, 11:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •