Results 1 to 10 of 10
  1. #1

    92 sea doo bombardier shuts off...

    I just bought the used ski. I took it out on the water a week ago for the first time and everything was great. A week later it just randomly dies, it will start right back up and run for a random amount of time and die. It always will start back up and run. The last time it died and I started it we drove it to shore with no issues...to add also, when we got home I pulled like 3 pounds of seaweed out of the intake so maybe that makes it turn itself off? anyone with any help on the cause would be appreciated...


  2. #2
    Also when I got home and removed the seat, the wire boot that is between the 2 spark plugs must have come disconnected...so I am not sure if that will cause it to run and shut off???..there should also be a photo attached...I appreciate all the helpClick image for larger version. 

Name:	20140622_131802.jpg 
Views:	54 
Size:	82.0 KB 
ID:	333438

  3. #3
    dolson's Avatar
    Join Date
    Apr 2010
    Location
    Massachusetts
    Posts
    635
    +1
    86
    That is the temp sensor. Mine comes off allot too. If it thinks the engine is too hot it will stall it. Use pliers and press on connector enough to close the gap but not too much were it won't go back on.

  4. #4
    Do you think that is the issue I am having that is making it turn off?

  5. #5
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    A corroded or loose connection somewhere will do it. Check for water in the e-box. Check fuses in box for corrosion and add di-electric grease to them. Also check for loose or corroded grounds. Could even be a faulty kill switch.

  6. #6
    dolson's Avatar
    Join Date
    Apr 2010
    Location
    Massachusetts
    Posts
    635
    +1
    86
    I have never had that connection off and the ski stall.

  7. #7
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    It doesn't matter, over tome the moisture causes a whiteish color corrosion that can make for a bad ground or connection.

  8. #8
    Great, can I run the jet ski for a long period of time if I hook it up to my hose to check if it stalls instead of having to launch it to see if there is an issue?

  9. #9
    Pull the fuel pick-up out of the tank and check the two pick-up tubes.

    They are made of some sort of rubber with a filter on the end.

    Mine had completely disintegrated and gave exactly the symptoms you've described.

    I replaced mine with two lengths of suitable size steel tubing.

  10. #10
    Had exact problem with mine when I got it pulled my hair out for months. It was the connection between the plug caps and the leads they weren't screwed in just pushed in and zip tied. Cut 1/4 inch off the lead cleaned with contact cleaner screwed the caps back on firmly and 2 years no probs. When the connection drops the computer shuts the engine down then you can start it again

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 Sea Doo Bombardier SPX Newbie questions ?
    By Professor Bob in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 09-03-2016, 08:27 AM
  2. 1999 Sea Doo Bombardier GTX Oil question
    By J.J in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-25-2016, 12:53 PM
  3. '92 Sea Doo XP 580 backfiring?
    By dubseven in forum 2-Stroke Performance
    Replies: 12
    Last Post: 08-15-2014, 03:21 PM
  4. Sea doo bombardier gtx 3 seater like new 1200.00
    By mrfixitusa in forum Sea Doo 4Tec Skis
    Replies: 1
    Last Post: 10-22-2008, 09:04 PM
  5. WTB 92 Sea-doo parts
    By Mac Daddy Racing in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 07-30-2008, 03:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •