Results 1 to 6 of 6
  1. #1

    Polaris Genesis 2001 NOT starting

    So I have this Genesis 2001 Bought Feb. 2002 as the original owner, its hours are under or just at 295 -300. based on explain to a few people & reading some other post on your website. I have started to lean to the Fuel pump.

    As battery has been charged up & it just will not Start it will Crank & Crank but NO start! But before I pulled the fuel pump out of the tank. I tested the power line coming into the pump. there was no power going to the pump. separated the Pig tail tested that there was no power either. So even if it is the fuel pump which sounds rather common. I still have No power coming into the pump! ANY thoughts on this one ??

    then we tried to test the power going to the bilge pump. that had no power either I was able to trace that wire into the Power box / fuse box. this was connected to the smaller fuse in the fuse box touch that sending unite with a little power then pump turns on.

    At this point I am thinking I need to addresses why these to areas are not getting power before I make the decision that the fuel pump I snot working. is there a solenoid or another switch I am not locating to find & trip or replace ?
    Last edited by K447; 06-30-2014 at 10:13 AM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Welcome

    Is this engine fuel injected or carburetor?

  3. #3
    it is Carburated

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by Jim D View Post
    it is Carburated
    There is no fuel pump in the fuel tank. The fuel pumps are mechanical, attached to the front and rear carburetors, powered by pulse hoses connected to the MAG and PTO crankcases.

    Do you have spark at the plugs?

    If no spark, hold down the Bilge button. Does bilge pump run?
    If yes, continue to hold down Bilge button and press Start. Do you now have spark?

  5. #5
    the bilge pump has no power either. traced that wire into fuse box and that fuse was blown. tester shows no power on either side of fuse

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by Jim D View Post
    the bilge pump has no power either. traced that wire into fuse box and that fuse was blown. tester shows no power on either side of fuse
    Bilge pump only has power when the engine is running or the Bilge button is pressed.

    If the bilge pump is shorted internally then the fuse will blow. Sometimes the fuses just fail from old age.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Polaris Genesis i - No start, nobody home
    By jg103 in forum Polaris Open Discussion
    Replies: 24
    Last Post: 07-17-2013, 01:35 PM
  2. 2001 Polaris Genesis FICHT WONT START PLEASE HELP!!!!
    By xBrenneckex in forum Polaris Open Discussion
    Replies: 37
    Last Post: 07-02-2013, 08:04 PM
  3. 2001 genesis - will not start
    By Cheepjeep80 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-29-2011, 10:22 AM
  4. my 94 polaris 750 will not start!
    By ducatifreak152 in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 06-03-2007, 12:52 AM
  5. 2001 Polaris Genesis won't start
    By Blink in forum Polaris How To & FAQs
    Replies: 11
    Last Post: 01-11-2007, 09:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •