Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: Engine bogging

  1. #1

    Engine bogging

    Need advise because I took my 2007 Aquatrax 12X a month ago after not putting her on the water for about a year. I still started her up from time to time and let her idle for about 10 minutes (running water of course). She started bogging down on low RPM's but still kicked some arse all the way to the red line. Cleaned her up and took her out again this past weekend and after launching it, this time it was bogging at all RPM's and could hardly go. Needless to say, I just put her back on the trailer and just went home.
    Can somebody tell me what I should check for? The plugs looked okay but my theory is that because all I did was idle the ski from time to time and was not revving it, the plugs just fouled up. Don't these turbo skis run rich on idle?
    Thanks. Jon


  2. #2
    I have a similar problem. I'm going to stay tuned...

  3. #3
    MattD's Avatar
    Join Date
    May 2013
    Location
    Hamilton, New Zealand
    Posts
    31
    +1
    8
    will most likely be plugs, they are very sensitive. Also make sure gas is fresh otherwise you will kill new plugs.

  4. #4

    Join Date
    Sep 2013
    Location
    BELGIUM
    Posts
    81
    +1
    2
    Could be the Off-Throttle Steering Solenoid valve that does'nt work properly . For a quick check : pull -off the tube of the controll diaphragm .
    If the solenoid valve does not open, the vacuum pulls the diaphragm rod up and give the high RPM .

    Click image for larger version. 

Name:	DSC00248.jpg 
Views:	44 
Size:	57.7 KB 
ID:	333766
    Last edited by STAVROS; 06-24-2014 at 02:51 PM.

  5. #5
    Quote Originally Posted by STAVROS View Post
    Could be the Off-Throttle Steering Solenoid valve that does'nt work properly . For a quick check : pull -off the tube of the controll diaphragm .
    If the solenoid valve does not open, the vacuum pulls the diaphragm rod up and give the high RPM .

    Click image for larger version. 

Name:	DSC00248.jpg 
Views:	44 
Size:	57.7 KB 
ID:	333766
    So I should pull that hose and check to see if it runs normal? I may be slow but I don't understand your directions...

  6. #6

    Join Date
    Sep 2013
    Location
    BELGIUM
    Posts
    81
    +1
    2
    Inderdaad.

  7. #7
    I took the hose off and it runs perfect! What should I do? Replace the valve? Can I just plug it off to bypass?

  8. #8

    Join Date
    Sep 2013
    Location
    BELGIUM
    Posts
    81
    +1
    2
    If you want to ride safe , change the solenoid valve !
    Last edited by STAVROS; 06-25-2014 at 03:32 PM.

  9. #9
    Changed the plugs on my ski this past weekend in she ran like a champ until I hit reverse then the bucket did not go into reverse. I was worried that my ski as taking in water so I beached it every time i stopped riding. Can somebody tell me if this is what I need to replace it with on Ebay? It was calling for 2 of these. One for reverse and one for steering. Also are these easy to replace? Thanks. HONDA AQUATRAX STEERING TRIM REVERSE BILLET ALUM NUT.http://www.ebay.com/itm/320822380923?ssPageName=STRK:MEWAX:IT&_trksid=p398 4.m1423.l2649.

  10. #10

    Join Date
    Sep 2013
    Location
    BELGIUM
    Posts
    81
    +1
    2
    I think they are not happy that Belgium won yesterday from the U.S. in football , because they removed my answer to your problem . ; O )) and your link does not work .
    Last edited by STAVROS; 07-02-2014 at 04:33 PM.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 VRX PRO engine bogging above 4500 rpm's
    By jeepinwi in forum Yamaha Old School Skis
    Replies: 14
    Last Post: 04-14-2009, 11:59 AM
  2. Engine bogging down
    By fdesorme in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 06-28-2008, 11:24 AM
  3. Engine bog above 4000 rpm, HELP!
    By waterburn in forum 2-Stroke Performance
    Replies: 10
    Last Post: 06-10-2008, 08:48 PM
  4. Engine bogs when letting off gas?
    By Velislide in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-02-2008, 11:00 PM
  5. seadoo gsx with 951 engine bogging at 35 or 40 mph
    By slamcharger in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-06-2006, 08:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •