Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    2000 Virage TX Phantom Electrical

    I have a 2000 Virage TX with a new battery and fresh NGK BPR9ES plugs. New CDI and Stator installed 15 hours of use ago and carbs rebuilt Nov 2005.
    The ski starts and idles fine, but bogs and backfires upon throttle. After disconnecting either wiring harness from the electrical box and reconnecting, it resets something and the motor then runs fine. This intermittent problem occurs after shutting down and restarting, even after only a few seconds (about every third time). I have installed the CDI jumper (as per the Polaris TSB) and checked all the electrical connections. Any thoughts on where to look next? Thanks - Scott


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407

    Check with Jay at.
    Atlantic Power Sports 10% off all OEM Parts, free UPS ground shipping on orders over 125.00. Ask for Jay(Service) Tony(Parts)
    Atlantic Powersports
    545 Mantoloking Rd.
    Brick, NJ. 08723
    Phone: (732) 920-7669 Fax: (732) 920-6789
    http://atlanticpowersports.com/
    e-mail us at [email protected]



  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Hey I need a Garage built I am looking at a two wide and four deep. Can you help?

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    So Scott you moved the red wire from the CDI to the orange post on the board correct?When it runs poorly, have you checked the voltage and current to the battery? If it's low, I'd suspect the voltage regulator.
    Let us know what you find.

    Oh and WELCOME to the Green Hulk Forums!!!

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Aw crap is that a jetti on the boat or a boat on the jetti???

  6. #6

    Boat on a jetti

    I'll check the voltage in the morning. I did move the red to the orange.
    Sorry I can't help with the actual construction of your garage. I only pimp them out! Also, I believe that jetti just jumped out of the lake.

    Thanks for the welcome and suggestions!

  7. #7

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9

    Cool

    this is going to sound mess up try unpluging display ( can not remenber if will even start unpluged) if can try someone display would be nice

    later cd

  8. #8
    I'm feeling naturally aspirated today pirate33's Avatar
    Join Date
    Aug 2006
    Location
    Lomita, aka Slowmita
    Posts
    1,932
    +1
    7
    In this one, a mountain jumped out in front of this boat
    Attached Images Attached Images  

  9. #9
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Quote Originally Posted by chip View Post
    this is going to sound mess up try unpluging display ( can not remenber if will even start unpluged) if can try someone display would be nice

    later cd
    That sounds interesting. I wish I had an MFD to send his way for a test.

  10. #10

    Boat Jump

    Man that's sad to see these boats all reefed up. I think that last one's a Hallett on Lake Havasu. I didn't have a chance to mess with the ski today or call Atlantic (maybe tomorrow). Thanks for the tips.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Virage TX no spark
    By torquenut3 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 05-24-2008, 10:55 PM
  2. 2000 virage tx electrical issues
    By gordon24 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-12-2008, 09:42 AM
  3. 2000 virage tx water/gas
    By gordon24 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-01-2008, 02:54 PM
  4. 2000 Virage TX Phantom Electrical
    By GarageDetailer in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 09-14-2007, 07:27 PM
  5. 2000 Virage tx 104 hours - should I buy it?
    By prt in forum Polaris Open Discussion
    Replies: 5
    Last Post: 03-30-2007, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •