Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    My Jet Ski drinks more than yours Glenozzy's Avatar
    Join Date
    Apr 2008
    Location
    SML, VA
    Posts
    725
    +1
    4

    speed loss on FX140 new pump old pump had a hole in the side

    Hello jetski nerds

    i am fixing my friend ski that had a bad pump " all of it "

    new drive shaft , pump, wear ring shoe everything but transom plate.

    ski top speed is 40mph i think 50 would be closer to real world

    pumps sound good, hook up very good stock prop

    what else could be damaged? motor has 350 hours but sound ok starts right up


  2. #2
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    did you install the correct pitch? if is too big it will lose power and mph.
    btw 59 to 60 mph is what you will see on that ski.

  3. #3
    fordgt's Avatar
    Join Date
    Sep 2013
    Location
    Brisbane, Australia
    Posts
    45
    +1
    6
    If you do need to get another replacement impeller, a 12/18 Solas Concord is absolutely perfect on mine.

    The dealership had replaced it with a Skat 13/19, but it was doing similar things to what yours sounds like.

  4. #4
    crashhard's Avatar
    Join Date
    Jul 2007
    Location
    Philly PA, Wildwood NJ, Indialantic FL
    Posts
    2,382
    +1
    24
    I don't think 59-60 but should be more then 40. Any chance you are actually doing more then 40 and just the speedo wheel is positioned wrong or damaged from the pump removal. Sometimes it's only the wheel.

  5. #5
    Air filter

  6. #6
    My Jet Ski drinks more than yours Glenozzy's Avatar
    Join Date
    Apr 2008
    Location
    SML, VA
    Posts
    725
    +1
    4
    tops out at 9500 rpm looking at air filter and spark plugs now

    it a real 40 MPH GPS say so

  7. #7
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    Quote Originally Posted by Glenozzy View Post
    tops out at 9500 rpm looking at air filter and spark plugs now

    it a real 40 MPH GPS say so
    this not a ho engine right? just a regular 1000.
    i don't believe the 140 is setup to run 9500 rpms , most like will be around 7800 to 8000.
    i quite sure the prop has the incorrect pitch.

  8. #8
    My Jet Ski drinks more than yours Glenozzy's Avatar
    Join Date
    Apr 2008
    Location
    SML, VA
    Posts
    725
    +1
    4
    the prop is stock marked 68n10

    shop manual say i should be running at 10,000 RPM at full throttle

    trouble shooting for loss of speed from the service manual
    Air filter
    gas filter
    spark plugs

    check compression

    this is a stock ski that the pump exploded with many broken parts

  9. #9
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    Quote Originally Posted by Glenozzy View Post
    the prop is stock marked 68n10

    shop manual say i should be running at 10,000 RPM at full throttle

    trouble shooting for loss of speed from the service manual
    Air filter
    gas filter
    spark plugs

    check compression

    this is a stock ski that the pump exploded with many broken parts
    well check compression and replace the plugs , and let us know. what kind of engine its?1000 or 1100?

  10. #10
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    also, unless the prop was purchase new from yamaha , how do you know if it had the right pitch and no one has mess with it?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Top speed loss on 14 fx crusiser svho: you make the call
    By scott2640 in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 06-04-2016, 06:27 PM
  2. Replies: 5
    Last Post: 08-31-2012, 08:18 PM
  3. Jet pump rattle at idle in the water
    By jackofalltrades in forum Polaris Open Discussion
    Replies: 19
    Last Post: 04-14-2012, 01:44 PM
  4. Replies: 0
    Last Post: 08-11-2010, 05:06 PM
  5. Compression loss on a new engine
    By Dawg in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-24-2010, 03:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •