Results 1 to 5 of 5
  1. #1

    2004 GTX wakeboard bad cold start.

    I have a 2004 GTX wakeboard edition(155HP), and the first time you start it up, it stalls (bogs) immediately. You have to give it a little bit to has to keep it going, and then it idles erratically until it warms up and then it runs perfect. Fires right up every time, idles perfect. It was showing codes for oil, so I'm putting new oil sensors on it, do not know if this will fix the problem or not. Thanks for any help.


  2. #2
    Got those sensors on. Still has a very erratic idle at startup until it warms up.

  3. #3
    Quote Originally Posted by Mixybro4 View Post
    Got those sensors on. Still has a very erratic idle at startup until it warms up.
    I believe that it has an idle air control motor on it. These often become fouled with debris and/or carbon and can benefit from a cleaning. As does the throttle plate. You might try cleaning both of these components and seeing what you've got before you start replacing parts.

  4. #4
    Could you possibly tell me where that is? And the best procedure on how to clean it.

  5. #5
    Quote Originally Posted by Mixybro4 View Post
    Could you possibly tell me where that is? And the best procedure on how to clean it.
    The IAC motor (seadoo calls it an idle bypass valve and it's #22 in the fiche) is located at the throttle body, as is the throttle plate. I have never removed an IAC from a PWC so I can't help you there, but if it's anything like the automotive applications you simply unscrew or unbolt it and clean the pintle (cone-shaped end that regulates air flow) and seat with a rag doused in carb cleaner. The throttle plate and throttle body bore can be cleaned the same way.

    It may also have a defective temp sensor that the ECU refers to when regulating air-fuel ratios during cold-start. In essence, the computer thinks the engine is already warmed up and adjusts air-fuel according to this misunderstanding.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 gtx 4 tec won't start
    By Riverrat1494 in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-09-2013, 10:48 PM
  2. 96 gtx 787, hard to start when cold...
    By Alex3012red in forum 2-Stroke Performance
    Replies: 4
    Last Post: 04-02-2013, 09:02 AM
  3. Need Help!! 2004 GTX 4 tec SC Wont Start
    By eddyk117 in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-15-2011, 08:44 AM
  4. seadoo 2004 gtx sc, long beep with key no start
    By carlosman in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-16-2010, 11:17 AM
  5. 2004 GTX wakeboard edition, not supercharged
    By rmaier4425 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-15-2010, 04:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •