Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    Seadoo XP 951 has limited rpm in water, 3500rpm!

    Hello!
    One of my seadoo xp LIMITED -99 do not want to stress over 3500rpm in the water but on land goes on as normal, the engine is just renovated with pistons, connecting rods, gaskets.
    Good comp and carburetors are also new renovated.
    Have one to exactly the same scooter that works really well so I've tested, exhaust, carburetor, MPEM, ignition coil, magneto, spark plugs, rave valves, jethus but still it does not work,
    Really have no idea anymore what it could be anyone know?
    Thank you!
    Simon


  2. #2

    Join Date
    Aug 2008
    Location
    Eastern NC
    Posts
    223
    +1
    8
    Check your jet pump

  3. #3
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    878
    +1
    11
    Sounds like it is running on only one cylinder,can you swap the spark plugs to verify from the other ski .

  4. #4
    Quote Originally Posted by hellhound007 View Post
    Check your jet pump
    Jetpump was rebuild 2 weeks ago, also tried switching with the working one without result.

    Quote Originally Posted by SURFnTURF View Post
    Sounds like it is running on only one cylinder,can you swap the spark plugs to verify from the other ski .
    tested and confirmed it running on both cylinders, already tried both new plugs and plugs from the working xp. No change.

  5. #5
    LVC's Avatar
    Join Date
    Dec 2013
    Location
    Loire Valley - France
    Posts
    82
    +1
    9
    Is the compression good on both cylinders on the rebuilt engine ?

  6. #6
    Quote Originally Posted by LVC View Post
    Is the compression good on both cylinders on the rebuilt engine ?
    130 psi on both cylinders when cold, same as the working one.

  7. #7

    Join Date
    Aug 2008
    Location
    Eastern NC
    Posts
    223
    +1
    8
    Have you checked the ignition timing?

  8. #8
    Quote Originally Posted by hellhound007 View Post
    Have you checked the ignition timing?
    Checked timing with timinglight, and it's the same as the working.

    also got a better compression tool and that tool is saying 124 psi on both, little low but should work.
    but to be sure I took the squish down to 1.4mm and got 145 psi MAG and 135 psi PTO.
    And it act exactly the same:/

  9. #9

    Join Date
    Aug 2008
    Location
    Eastern NC
    Posts
    223
    +1
    8
    Have you tried swapping the rectifier?

  10. #10
    Quote Originally Posted by hellhound007 View Post
    Have you tried swapping the rectifier?
    It's built in the MPEM and I have tried another MPEM.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 seadoo xp 951 throttle problems? Taking on water?
    By 951 XP NC in forum 2-Stroke Performance
    Replies: 5
    Last Post: 04-07-2014, 12:05 AM
  2. '97 sltx 1050 only hitting 5200-5300 rpms in water
    By roscofisher11 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-05-2009, 10:50 AM
  3. seadoo xp 951 speed record ???????
    By eroled185 in forum 2-Stroke Performance
    Replies: 32
    Last Post: 04-01-2008, 04:59 PM
  4. Seadoo XP 951 ???????????
    By trent0715 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 03-07-2008, 01:32 AM
  5. 250X idles at 2200 RPM in water
    By kman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 09-11-2007, 08:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •