Results 1 to 5 of 5
  1. #1

    polaris sl650 bogging problem

    Hi everyone, I was hoping someone could help me out I have a 1994 Polaris sl650 I purchased the ski last summer and had good luck with it till the end of the season I blew a crank seal and melted a piston. So a month ago I ordered a reman engine from SBT I rebuilt the carbs with mikuni rebuild kits, new triple outlet fuel pump, and new gas line and removed the auto cock, but the problem im having is that out of the water it will rev up with no problem but once in the water it will idle fine but once you give it throttle it bogs and stalls but when you use a little choke it will take off and stay running if you keep it at high rpm I set the carbs at the factory settings and when that didn't work I turned out the high speed jets a quarter and then I turned them half a turn and didn't make no difference and now im at a stand still with it. Also none of the boat and pwc shops around were I live wont even look at. Thank you


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Welcome to the Hulk!! Where are you located?

  3. #3
    Hi thanks I am located in dubuque iowa

  4. #4
    waterdog1971's Avatar
    Join Date
    Oct 2010
    Location
    goodspring, tn.
    Posts
    173
    Quote Originally Posted by 7941sam View Post
    Hi everyone, I was hoping someone could help me out I have a 1994 Polaris sl650 I purchased the ski last summer and had good luck with it till the end of the season I blew a crank seal and melted a piston. So a month ago I ordered a reman engine from SBT I rebuilt the carbs with mikuni rebuild kits, new triple outlet fuel pump, and new gas line and removed the auto cock, but the problem im having is that out of the water it will rev up with no problem but once in the water it will idle fine but once you give it throttle it bogs and stalls but when you use a little choke it will take off and stay running if you keep it at high rpm I set the carbs at the factory settings and when that didn't work I turned out the high speed jets a quarter and then I turned them half a turn and didn't make no difference and now im at a stand still with it. Also none of the boat and pwc shops around were I live wont even look at. Thank you
    We're in the same boat (no pun intended) I have the exact same problems accept I have a '96 SL780. Here's the link to the thread I started if you want to check out the info the guys on here have given me so far, a LOT of good info, http://www.greenhulk.net/forums/showthread.php?t=140787

  5. #5
    Hey thanks your thread had A Lot of good info and im planning on following your thread to see what you come up with I never thought about putting in bigger jets thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 Polaris SL650 bogging????
    By jajardas in forum Polaris Open Discussion
    Replies: 16
    Last Post: 07-08-2014, 09:01 AM
  2. 1995 polaris sl650 problems
    By jburg78 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 07-06-2012, 11:38 AM
  3. 2000 Polaris Slh Bogging problem off Idle
    By polarisbuyer in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-21-2011, 09:42 PM
  4. polaris sl650 bogs down HELP!!!!!!!!!!!
    By allyfonzo in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-23-2010, 03:05 PM
  5. 1994 Polaris SL650 more problems
    By katz1002 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-08-2009, 10:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •