Results 1 to 2 of 2
  1. #1
    thetolleyman's Avatar
    Join Date
    Jul 2010
    Williamsburg, VA

    Fuel pump stopped pumping a good supply of fuel, the pulse line is not pulsing?

    Ski quit today, but I could get it to run by spaying fuel in carb so I suspected fuel supply issue of course. Turns out the pulse line isn't pulsing normally. It just blowing out a pretty large volume of air as I crank over starter, any ideas what would cause this?

    this is on 760 motor, single carb.

  2. #2
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    broken reeds petals.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sbt jet pump housing (new replacement) good or bad?
    By toyota4x4s85 in forum Open Discussion
    Replies: 4
    Last Post: 05-01-2013, 03:47 PM
  2. No fuel in accelerator pump
    By pplusent in forum Polaris PWC Performance
    Replies: 10
    Last Post: 05-14-2012, 09:54 PM
  3. FS 1300R fuel tank and pump
    By L Carlson in forum Yamaha Classifieds
    Replies: 1
    Last Post: 03-31-2010, 09:11 PM
  4. F/S: SS 800 Grate, Conversion Mounts, Pump Adapter & Pump, Rideplate, ETC.
    By JFizzleJR in forum Conversion Skis Classifieds
    Replies: 13
    Last Post: 02-11-2009, 09:14 PM
  5. do I remove fuel shutoff during pump replacement
    By falcon in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 03-16-2007, 10:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts