Results 1 to 2 of 2
  1. #1

    2000 GTX Millennium Edition running rough.

    A couple of my friends bought a pair of HO Sparks, and her parents decided they wanted to ride with us so they picked up the GTX. Has around 70 hours on it.

    The first day they came out with us it ran great.
    The 2nd time they went out it ran great for 15 min , and then it started bogging badly from what they told me.

    I suggested they change plugs , and see what happens. Today they took it out ,and it ran great again for around 15 min ,and then started to bog.

    Any idea what might be causing this?
    Thanks.


  2. #2
    sounds like plugs fouling up with oil
    remove plugs and check the cooler if you have oily deposits on them.
    confirm its a 951 2 stroke engine and how many hours since new or repair???

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 seadoo gtx millennium edition
    By jp003 in forum Open Discussion
    Replies: 1
    Last Post: 07-19-2015, 10:02 PM
  2. 2000 GTX Millennium Edition oil choice.
    By abmobil in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-22-2014, 12:04 AM
  3. 2000 seadoo gtx millennium edition right mirror
    By hunt-dog in forum 2-Stroke Performance
    Replies: 0
    Last Post: 08-23-2010, 07:17 PM
  4. 2000 GTX Millennium Edition Help
    By regulator26 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-20-2009, 08:26 PM
  5. 2000 GTX ltd edition - looking for pro advice..
    By jetski_poland in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-24-2008, 07:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •