Results 1 to 3 of 3
  1. #1

    Having trouble with timing cover

    My washer blew up in my motor and I'm trying to replace the oil pumps I cannot get the timing cover to line up

  2. #2

    Join Date
    Aug 2009
    McKinney, TX
    Are you talking the whole pto cover? Check the 2 pins in the cover or motor are not duplicated and make sure the oil pump shaft is aligned with the counter balancer. Also check the bendix gear and washers

  3. #3
    When you say your washer went or blew up in your engine did it have to come out and be clean right through. Having the same problem now and wondering what to do. Or how much it will cost.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Any one having trouble with there fuel pump on a 300x
    By Kev273 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 18
    Last Post: 12-17-2013, 03:50 AM
  2. having trouble with my buddies suped 07 rxt
    By dnice07rxp in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-08-2008, 11:26 AM
  3. HAving troubles with 4tec
    By moto17 in forum 4-Tec Performance
    Replies: 10
    Last Post: 10-08-2007, 12:14 PM
  4. having trouble with 02 4tec info
    By seadoor in forum 4-Tec Performance
    Replies: 0
    Last Post: 09-24-2007, 07:12 PM
  5. For those having trouble with the stock class ECU
    By Green Hulk in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-17-2006, 12:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts