Results 1 to 10 of 10
  1. #1

    Join Date
    Aug 2009
    Location
    McKinney, TX
    Posts
    124
    +1
    1

    RXT only turning 7600 RPM and 54 MPH GPS??

    Fresh engine, oem wear ring and sbt rebuilt impeller 88 hrs on ski. All stock on a 2005 rxt. Only change is that I installed an xcharger from a 2010 rxp with 71 hrs while I wait on my stock charger that's being rebuilt by jerry. I also have a stock 05 gtx limited turning 8100 and 64 mph 164 hrs. What gives?


  2. #2
    TheGunMan's Avatar
    Join Date
    Feb 2013
    Location
    Las Vegas
    Posts
    454
    +1
    41
    X charger needs bigger /42#/ injectors. You may be lean

  3. #3

    Join Date
    Aug 2009
    Location
    McKinney, TX
    Posts
    124
    +1
    1
    I read with everything else stock, oem injectors are fine. Even so, I don't see that being a 10mph issue??

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Some thing is holding the ski back. I had an 05 RXT and at 7600 rpm, you should be going 60-61 mph.

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    Check the SBT impeller make sure its the correct pitch and clearances are correct.

  6. +1 by:


  7. #6
    twokexlv6coupe's Avatar
    Join Date
    Jul 2011
    Location
    north jerz
    Posts
    568
    +1
    54
    More air without more fuel make engine go boom.

  8. #7
    achavanne3's Avatar
    Join Date
    Jun 2014
    Location
    Louisiana
    Posts
    130
    +1
    7
    My stock rxp at 7600 goes 65 on gps. (Gauge on ski says 69). I've heard the hot weather has som affect but considering you tested another ski I'm not so sure..

  9. #8
    achavanne3's Avatar
    Join Date
    Jun 2014
    Location
    Louisiana
    Posts
    130
    +1
    7
    Also my ski does not put out 8100 rpms... 7600 is wide open for me

  10. #9
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Did it get the knock sensor piggtail harness update done? May not need it with 05's but 04's needed it.

    Is the oil over the halfway mark on the dipstick?
    Has the nose cone on the prop come loose, or slid up the shaft?
    What is the slip on the Current Charger set at?

  11. #10
    achavanne3's Avatar
    Join Date
    Jun 2014
    Location
    Louisiana
    Posts
    130
    +1
    7
    Quote Originally Posted by psycho rxp View Post
    Did it get the knock sensor piggtail harness update done? May not need it with 05's but 04's needed it.

    Is the oil over the halfway mark on the dipstick?
    Has the nose cone on the prop come loose, or slid up the shaft?
    What is the slip on the Current Charger set at?
    Have not checked anything on the sc

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 25
    Last Post: 06-05-2014, 01:29 PM
  2. Replies: 9
    Last Post: 06-03-2010, 01:37 AM
  3. those with 04 RXP's or 04 RXP ECU's in conversion skis and are only getting 7600 rpm
    By Green Hulk in forum Conversion PWC Performance Skis
    Replies: 1
    Last Post: 07-25-2009, 05:24 PM
  4. RXP only turning 7500 rpm ????
    By joeschoonover74 in forum 4-Tec Performance
    Replies: 13
    Last Post: 04-29-2007, 07:43 PM
  5. 600 RPM and 5 mph Loss?
    By Red Devil in forum 4-Tec Performance
    Replies: 30
    Last Post: 07-28-2005, 09:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •