Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,206
    +1
    458

    Throttle body failure

    So who else has had a throttle body fail on a 2014 FZ? Fault code 115 on the display. It wasn't 15 minutes of her maiden voyage when all hell broke loose. Ever try docking or loading a ski while the engine is turning 2200RPM? A lot of quick thinking went on. Lol. Now back to the dealer in the morning.
    Last edited by Guidoo; 06-29-2014 at 01:51 PM.


  2. #2

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,847
    +1
    528
    Quote Originally Posted by ScramblerKidd View Post
    So who else has had a throttle body fail on a 2014 FZ? Fault code 115 on the display. It wasn't 15 minutes of her maiden voyage when all hell broke loose. Ever try docking or loading a ski while the engine is turning 2200RPM? A lot of quick thinking went on. Lol. Now back to the dealer in the morning.
    sorry to here the bad news, Hopefully it something simple and easy to repair! Tommy Jordan

  3. #3
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,206
    +1
    458
    I popped the seat and looked around. Didn't see anything loose. It would slightly increase RPM when I pulled the throttle. I'm thinking throttle body took a dive. Maybe I can get them to do a ribbon delete while if the TB has to be changed. Save me the trouble of doing it later.

  4. #4
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    kinda odd, but possible, just sucks on your first ride, but better than the ride the day after the warrantee expires

  5. #5
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,206
    +1
    458
    True. Very true.

  6. #6
    Just be glad you dont have to buy a new TB. They are of the simplest of sensors in the skis, and cost about 23X more then they should

  7. #7
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,206
    +1
    458
    I know, over $800.

  8. #8
    Harness could cause this. Did you trace the wire back to the ecu, pull it from the plug and use a multimeter with the diode test and see if you have a break in the wire or a faulty ecu?



  9. #9
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,206
    +1
    458
    Nope but thanks. Turned out to be a piece of rubber stuck in the throttle body. Now the $14499 question is where did it come from? It's about 4" long with a H cross section. I hope it's not a separator from the intercooler. I'll post pictures in a few.

  10. #10
    @JC's Avatar
    Join Date
    Sep 2012
    Location
    The Peoples Republic of Minnesota
    Posts
    1,862
    +1
    994
    Did they pull the ribbon for you while they had it off?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. THROTTLE BODY Failure
    By db2540 in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 04-13-2014, 07:36 AM
  2. Bored throttle body
    By Green Hulk in forum 4-Tec Performance
    Replies: 61
    Last Post: 09-10-2007, 01:01 PM
  3. Procedure for swapping ECUs and Throttle Bodies?
    By Jarrett in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-29-2006, 12:40 AM
  4. Intake manifold? Throttle body?
    By 01xdime in forum 4-Tec Performance
    Replies: 21
    Last Post: 10-06-2005, 11:22 AM
  5. WTB Throttle Body for project
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-18-2005, 10:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •