Results 1 to 2 of 2
  1. #1

    Help please! 2000 speedster sk 240

    Just bought the darn thing and im having an issue. I get no throttle response while in the water. It sounds like it is reving just fine when i hook the hose to it, but im too affraid to push it to far with just the hose. In the water i push forward on the throttle and nothing happens. Halfway through it acts like it wants to go but nothing happens. Guy i bought it from says he had all the carbs redone and the fuel system cleaned and checked within the last 2 weeks. The throttle cable does move in the engine compartment. Any ideas? Suggestions?

    thanks for your time
    Luke


  2. #2
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    I would re-check the carbs and internal fuel filters inside the carbs. Also check the fuel pump and pulse line going to the carbs. What is your compression at on the engine?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Performance-2000 speedster sk 210hp mercury m2
    By Pepper 2111 in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 10-01-2014, 05:20 AM
  2. Need help.. pls 2000 Challenger (Merc 240 EFI)
    By wcmateiuc in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 08-16-2012, 08:34 PM
  3. Newb Needs help please! 2000 SLX rev limit stuck on
    By Full Throttle Speed in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-03-2011, 09:32 AM
  4. New to the forums... my 2000 Speedster just died :( Help?
    By Boss in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 08-03-2007, 10:24 AM
  5. New to the forums... my 2000 Speedster just died :( Help?
    By Boss in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 07-27-2007, 08:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •