Results 1 to 4 of 4
  1. #1

    MSX 110 taking on water

    Hello everyone, I have a MSX 110 i got from a guy who said he though he had cross threaded the plugs and didn't notice in which he filled up the ski and had problems. long story short of that is i did about 5-6 oil changes and i got all the milky oil out and it runs well (so i think at least, haven't really jumped on it or anything) but it had taken on a pretty good amount of water, so i took it out let it drain out and took it out again and found from what it looks like something spraying water when it runs from under the oil reservoir.
    any ideas you guys might have to as what is going on i would greatly appreciate it. also the plugs seem to seal so i don't think thats it and from what i want to say is the water is coming in when the ski is running.

    thanks alot


  2. #2
    hill160881's Avatar
    Join Date
    Jun 2014
    Location
    The delta Ca
    Posts
    2,043
    +1
    246
    Its either a leaking hose that attaches to the oil tank or the tank is cracked. I would pressure test the tank and check all hoses connecting to it.

  3. #3
    Quote Originally Posted by hill160881 View Post
    Its either a leaking hose that attaches to the oil tank or the tank is cracked. I would pressure test the tank and check all hoses connecting to it.
    thanks for the advice Hill, i'll check it out. i'm pretty sure that the tank is not cracked since i can't feel anything on it.


    Does anyone have a diagram that shows the entire fresh water system?

  4. #4
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    The freshwater hose from the heat exchanger (under the intake manifold) to the oil tank is the one spliced into for the flush kit. Does yours have a flush kit, Tee, adapter in it? Check there to make sure not leaking or anything. Or follow the hose with your hand and check for any tears/cuts in it.

    There are diagrams for the freshwater system on page 4.60 and 4.61 in the service manual.

    Cheers!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. polaris msx 140 slowly taking on water when engine is running
    By mitch04 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 01-19-2013, 08:26 AM
  2. polaris 750sl taking on water
    By jeff joiner in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 05-09-2007, 08:58 PM
  3. 04 RXP taking on water, can blower be culprit?
    By JCHOUCK in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-14-2006, 10:20 AM
  4. does the rxp take on water easily??
    By CarFanatic in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-30-2006, 08:09 AM
  5. RXP-Taking on water
    By RXPDAVID in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-10-2005, 06:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •