Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22

Thread: Lost RPM, why??

  1. #1
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76

    Lost RPM, why??

    So I took my RXP out this morning. I'm normally getting 7900 @ WOT but now I'm only getting 7700-7750 @ WOT. Could this be heat soak? Slipping supercharger? Worn wear ring or pump related? Just curious and would hate to lose the ski due to a SC failure


  2. #2
    AtoMIC_OraNGE greenbullet's Avatar
    Join Date
    Jul 2010
    Location
    Barrie / BuckHORN Ontario
    Posts
    2,509
    +1
    234
    It's hot but your rpm are low to begin with. Either learn the hard way or send your charger for rebuild. You should turn 8100 easy. You need to have a strong charger first and the pitch the prop

  3. #3
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76

    Lost RPM, why??

    Delete

  4. #4
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76
    When I get paid next I'm going to buy a new 215 SC'er. I don't want to rebuild because I don't want to lose any time out on the water. As far as being got the weather has been around 30* so that would explain why

  5. #5
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76
    I'll worry about having the prop pitched after the summer, when I flip my wear ring

  6. #6
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by SuperCharged67 View Post
    So I took my RXP out this morning. I'm normally getting 7900 @ WOT but now I'm only getting 7700-7750 @ WOT. Could this be heat soak? Slipping supercharger? Worn wear ring or pump related? Just curious and would hate to lose the ski due to a SC failure
    Pitch prop to 8100 for your normal WOT rpm and you will not lose as much rpms when hot. Acceleration will feel a whole better too.

  7. #7
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76
    Okay sounds good, was just worried about it being a slipping SC'er

  8. #8
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Get the tools, start doing things yourself...No down time then

  9. #9
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76
    I'll leave the supercharger rebuilding to the pros as it seems complex, but pulling and installing is no problem.

  10. #10
    Supercharged67 how many hours on your ski?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT 255 lost 200 rpm, WHY?
    By Impulses in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-23-2015, 06:18 AM
  2. RXP lost rpms
    By RedRyderRXP in forum Sea Doo Open Discussion
    Replies: 28
    Last Post: 07-13-2006, 12:59 AM
  3. Lost RPM after installing RIVA Power Filter...help!
    By RXP-REX in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-29-2006, 06:39 PM
  4. lost rpms
    By MDGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 05-19-2006, 03:07 AM
  5. lost rpms after fiting solas 14/19
    By Top banana in forum 4-Tec Performance
    Replies: 6
    Last Post: 10-10-2005, 06:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •