Results 1 to 7 of 7
  1. #1

    Lost 1 100 rpm/15 mph due to loose fitting from intercooler to sc

    I'm only revving 6900 rpm and top speed of 53 mph on my 215 gtx . I thought immediately about the supercharger so i shut it down. I used to rev 8150 and got 70 ish top speed.Upon inspection my fitting from my riva intercooler to the supercharger came loose. Would this cause this much of a performance drop and why? Apparently the supercharger was rebuilt 5 hours ago so I don't know if I should check it out or not. Please explain .


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    any boost leaks are bad leaks
    are the hoes clamps worm clamps or t-bolt clamps
    worm clamps are not the best clamp for boost or exhaust connections
    Last edited by skidoochris; 07-02-2014 at 07:23 AM.

  3. #3
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,625
    +1
    806
    Quote Originally Posted by Apocalapsi View Post
    I'm only revving 6900 rpm and top speed of 53 mph on my 215 gtx . I thought immediately about the supercharger so i shut it down. I used to rev 8150 and got 70 ish top speed.Upon inspection my fitting from my riva intercooler to the supercharger came loose. Would this cause this much of a performance drop and why? Apparently the supercharger was rebuilt 5 hours ago so I don't know if I should check it out or not. Please explain .
    The answer is yes. It basically turns into an NA 155 but worse due to sucking in stagnant hot air.

  4. #4
    I'm really surprised. I loosened the clamps attaching my intercooler to the supercharger after installing a groco strainer and fforgot to tighten it. So the intercooler shifted off the hose. Why would that affect rpm? I understand power would be down but rpm too? Especially that much? It almost seemed that the supercharger wasn't working. Could someone explain. I mean the supercharger should still be working it's just that it is not getting cool air from the intercooler right?

  5. #5
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,625
    +1
    806
    All the air from the supercharger is losing pressure (boost) and leaving the intake system by way of giant air leak.

    Quote Originally Posted by Apocalapsi View Post
    I'm really surprised. I loosened the clamps attaching my intercooler to the supercharger after installing a groco strainer and fforgot to tighten it. So the intercooler shifted off the hose. Why would that affect rpm? I understand power would be down but rpm too? Especially that much? It almost seemed that the supercharger wasn't working. Could someone explain. I mean the supercharger should still be working it's just that it is not getting cool air from the intercooler right?

  6. #6
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    As far as the engine is concerned, the supercharger is not working ... all the boost is escaping, and not being pushed into the motor. Its kind of like pouring a big cold beer in a glass, then pouring it on the ground and wondering why you are not refreshed ...

  7. #7
    Aussiepauly's Avatar
    Join Date
    Jan 2012
    Location
    Sydney Australa
    Posts
    898
    +1
    70
    Definitely your problem! No pressure so no go!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I assume I am loosing rpm/mph due to this sc wheel?
    By Yanksfan in forum 4-Tec Performance
    Replies: 12
    Last Post: 09-15-2016, 09:26 PM
  2. 09 SHO lost 15 mph top speed
    By Sikes44 in forum Yamaha PWC Performance (4-stroke)
    Replies: 20
    Last Post: 02-16-2013, 03:39 AM
  3. Replies: 20
    Last Post: 05-21-2012, 02:51 PM
  4. How much MPH gain to you get per 100 rpm you gain??
    By ModularJunk in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-13-2011, 10:18 PM
  5. How many have lost engines due to the higher RPM limit in the reflashes or ecus?
    By 556SBR in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 10-25-2010, 03:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •