Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Sep 2010
    Location
    Daytona Florida
    Posts
    607
    +1
    10

    Supercharger question

    I know this is a boat but I'm pretty sure I know the issue, I'd like some second opinions before I move forward.

    It was a 07 180 se challenger. single 215hp with under 50hrs. Washers done at 12hrs when he got the boat. It ran fine this past sunday. Guy doesn't know enough to make up what happened next.

    Boat looked alright. Cranked it up and about a minute later it screeched like a tire drug down the road. Turned it right off. Tried it again and it was quiet, then touched the throttle and the screech again. Turned it off. He was wide eyed, what the heck was that noise? I've never heard that before, he actually freaked out trying to turn the boat/water off correctly.


    bearings in the supercharger, correct?

    Obviously I passed on it but this might be a good time to pick this up cheap and put an X on it.

    am missing any details on the screech that might bite me in the arse, like some parts taking off into the engine i.e. the washer issue?


    Thx guys.


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    maybe flywheel bolts sheared off

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Screech could be anything......SCer,motor,Pump,driveshaft,prop..... ...did you isolate the area to the motor???

  4. #4

    Join Date
    Sep 2010
    Location
    Daytona Florida
    Posts
    607
    +1
    10
    I was right over engine and it sure sounded right there. Started up 1st time immediately and idled smoothly, then the squeel about 30 seconds into it, shut it off myself. Restarted immediately and idled smoothly. It was quiet, then gave it a small rev and it squeeled again, shut it off myself. That's my extent of looking into it.

    I did notice the SC whine as it spooled up when 1st started, I was standing over the engine. The 2nd start-up I never really heard it spool up. Sure seemed to be the engine compartment area. No alarms went off.

  5. #5

    Join Date
    Sep 2010
    Location
    Daytona Florida
    Posts
    607
    +1
    10
    If I go back(1.5hrs) and pull the intake, will I be able to see if it's the supercharger bearings by wiggling or use a mirror/flashlight to see something that would indicate this? It looks incredibly easy to pull the charger on the skis but not so sure on the challenger and certainly not in the guys driveway.


    thx for any pointers.

  6. #6
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,248
    +1
    544
    remove the intake tube and try spinning the supercharger wheel. it should have slight movement (gear mesh). I have done a bunch of 07 C180's in the past couple years. For some reason sport boats kept the shitty supercharger clutches ( not sure what year they upgraded)

  7. #7
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    ..IF you have any suspect of a bearing failure then i would just pull the SCer out completely and inspect it...IF a bearing has let go chances are you wont be able to spin the Scer impeller anyway......Only real way to know is to pull it completely out..

  8. #8

    Join Date
    Sep 2010
    Location
    Daytona Florida
    Posts
    607
    +1
    10
    I'll pull it for sure but I'd have to do that at my home, I'm just asking if that's what we think it is based on the engines actions when it happened. The last thing I want is an engine full of blower debris.

  9. #9
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    It's hard to say.....until you have a start somewhere it could by anything..you have a lot of moving parts in that area...

  10. #10

    Join Date
    Sep 2010
    Location
    Daytona Florida
    Posts
    607
    +1
    10
    went back bought the boat. My buddy had a riva washered charger so I slapped that on and she was quiet and ran great. The other charger had some lateral movement in the shaft, very minimal but there. It did have metal washers.


    boat with me in it and half tank ran right to 44-45 and did 47mph at most on the dash and showed 7850 top rpm. I guess I could have held it more but that was about it. Slight chop and hot water and hot air. Boat was only ran about 3-4 minutes so not really heat soaked.

    Though these guys turned 8100 like the skis?

    am I wrong on this?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Supercharger question?
    By dave262626 in forum 4-Tec Performance
    Replies: 13
    Last Post: 11-21-2008, 01:18 AM
  2. 03 GTX SC, supercharger question
    By gbest in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-08-2008, 04:09 PM
  3. Supercharger Question
    By carl sagan in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-03-2007, 09:33 PM
  4. supercharger question
    By Kinchyle in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-08-2005, 03:33 PM
  5. Supercharger questions
    By Ed in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 05-25-2005, 03:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •