Results 1 to 10 of 10
  1. #1
    tpd's Avatar
    Join Date
    May 2008
    Location
    Hamburg, NY
    Posts
    263
    +1
    25

    The Suspense is Killing Me!!!

    Picked up a left over 2013 RXT-X yesterday. By the time I got done at the dealer and back to the lake it was too late to ride. And of course today it's been raining all day. GRRRRR, I wanna ride this beast!!!!


  2. #2
    Q in Arizona's Avatar
    Join Date
    May 2013
    Location
    Phoenix, Az
    Posts
    30,542
    +1
    7,347
    Congrats.

  3. #3
    Ten hour break in Danielsan.

  4. #4
    Tbranella's Avatar
    Join Date
    Feb 2013
    Location
    Galloway Twp. NJ
    Posts
    571
    +1
    71
    I got a little over 3hrs on mine so far!
    Click image for larger version. 

Name:	2014-06-22 14.09.28.jpg 
Views:	41 
Size:	64.8 KB 
ID:	334772

  5. #5
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    tpd, Congrats are your T-X. Some friendly advice while you are waiting for the weather to clear up. Read the dang owners manual several times and practice raising the iBr gate in the sub-menu (IBR OVR Procedure). This is good to know for pump access and clearing debris. Put a wrench on every bolt, screw, hose clamp that you can get to as you WILL find some that are loose. Read closely what it says on how to break in the engine.

    Get a hard copy of the Shop Manual from the dealer or get a pdf version here: www.brpmanuals.com

    Have fun!


  6. #6
    tpd's Avatar
    Join Date
    May 2008
    Location
    Hamburg, NY
    Posts
    263
    +1
    25
    Thanks guys!! I've been reading this manual for the past 2 days, but glad you mentioned the IBR function, it's one thing to read it, but another to do it.

    Looks like today will be her maiden voyage!!!

  7. #7
    ride it like you stole it!!! raceneked's Avatar
    Join Date
    Sep 2011
    Location
    Lake Havasu, AZ
    Posts
    3,021
    +1
    840
    ...find another way, or reinforce, the way the siphon tubes are hung at the rear of the ski in the engine bay. If the cute little feeble zippy-ties fail, it can become problematic for you.

  8. +1 by:

    tpd

  9. #8
    tpd's Avatar
    Join Date
    May 2008
    Location
    Hamburg, NY
    Posts
    263
    +1
    25
    Get it out today for a while. What a machine!! Even keeping it half throttle the majority of the time in tour mode was fun. I did get on it up to about 50 in sport mode a couple times too, it gets there in a hurry!!! Holy cow, can't believe how responsive the throttle control is. It was windy today so it was nice to see the ride in the chop, I can't believe how much smoother it rides.

    I popped the seat after riding and noticed a little water left in the bottom of the hull near the front of the engine, this normal??

  10. #9
    tpd's Avatar
    Join Date
    May 2008
    Location
    Hamburg, NY
    Posts
    263
    +1
    25
    And why does display show I have 0 miles left or riding when I have a half tank of gas? also seems like the max speed and max RPM reset everytime, is that normal?

  11. #10
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    Can't explain the 0 miles left feature. Yes every time you pull the key off the max rpm, speed etc. reset. They are also bogus numbers because you come un-hooked and spike the values, just ignore them all.

    Also, BRP wants to lie and display 1-2 mph higher than actual GPS values. My MOTEC M130 logs the actual CAN BUS GPS values to the tenth and is perfectly the same as 2 Garmin GPS units, BUT the dash display is always 1-2 mph more than actual. Go figure.....

    Most guys ignore the AVG and peak values displayed........

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stumped! My GP1300 is killing me.
    By OzarkYamMonster in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 05-11-2015, 09:47 AM
  2. Arghhhh! this weather is killing me
    By 3PedalMINI in forum Open Discussion
    Replies: 10
    Last Post: 05-28-2013, 12:32 PM
  3. ZXI 1100 Is killing me! Shoot me now! .
    By cjw in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 08-21-2012, 10:27 PM
  4. This lc1 is killing me!!
    By tocullo in forum 4-Tec Performance
    Replies: 28
    Last Post: 05-09-2012, 11:48 AM
  5. Need Help! My Trim Is Killing Me
    By xanthras in forum Polaris Open Discussion
    Replies: 20
    Last Post: 08-18-2008, 11:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •