Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    250 ultra problem

    Hello , i have in my workshop ultra 250 , i have this problem , Many times having accelerated to a minimum also shuts off the water the motor runs fine but just put in water looks almost as if turned very rich in gasoline. The spark plugs were changed, the strap and perfect, but I can't figure out why it doesn't work. When the fires and how if I measure larger injectors. Thanks for the advice


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    check the s/c and intercooler and inlet trumpet, sounds like its not getting enough air

  3. #3
    Quote Originally Posted by nicjak View Post
    check the s/c and intercooler and inlet trumpet, sounds like its not getting enough air
    Thanks for your answere , sorry when i traslate what s trumpet?, s/c is good. Thanks

  4. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    the air intake rh side

  5. #5
    Quote Originally Posted by nicjak View Post
    the air intake rh side
    Ok , this is alluminium part, what problem have this?

  6. #6
    When broken sensor pressure what problem we have? And this ski have problem with head crack, if i have this i see OIL contamination from water, correct?

  7. #7
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    no, it sits above the fuel tank remove the eco cover and ecu and look in its rubber and shaped like a trumpet.

    Quote Originally Posted by samui View Post
    Quote Originally Posted by nicjak View Post
    the air intake rh side
    Ok , this is alluminium part, what problem have this?

  8. #8
    Thanks Nic , have riva air filter.

  9. #9
    Out side water is Tiger , inside water is same we have injectors Very big.

  10. #10
    Quote Originally Posted by samui View Post
    Out side water is Tiger , inside water is same we have injectors Very big.

    2009 260 ultra . got the same problem for a year now.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. problem 250 ultra
    By samui in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 07-21-2014, 04:01 PM
  2. Ultra 250 fuel problem?
    By 2old2paddle in forum Kawasaki PWC Performance (4-stroke)
    Replies: 20
    Last Post: 10-12-2011, 06:37 PM
  3. 250 X ultra problem, help needed
    By kellz24 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 12-16-2009, 09:47 PM
  4. ultra 250 rpm problems
    By yamahamike125 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 09-21-2009, 06:42 AM
  5. Problem whit kawasaki 250 ultra!!
    By jimjon in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 05-17-2009, 03:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •