Results 1 to 7 of 7
  1. #1
    TheGunMan's Avatar
    Join Date
    Feb 2013
    Location
    Las Vegas
    Posts
    454
    +1
    41

    Driveshaft installet correctly?

    Did I installed my driveshaft correctly?

    In the service manual is said that the tailtale groove jas to NOT be visible if the shaft is correctly installed in the PTO. I can see "griove" but the shaft can not go any further and the bearing can not slide more back on the shaft. There is pic of the install. Let ne know if it is good or not and if not how to correct it

    thanks

    P. S. This is 07 RXP
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	89 
Size:	81.8 KB 
ID:	334722  


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Your good..... go ride!

  3. +1 by:


  4. #3
    TheGunMan's Avatar
    Join Date
    Feb 2013
    Location
    Las Vegas
    Posts
    454
    +1
    41
    Thanks

    i was wirried about the groove they stress on in the manual. I even took the driveshaft out and installed it again and the result was the same

  5. #4
    Did you read the manual for directions or something else I'm putting my motor back in tomorrow and the drive shaft is my main worry about getting it back in correctly with the circlip!!??

  6. #5
    TheGunMan's Avatar
    Join Date
    Feb 2013
    Location
    Las Vegas
    Posts
    454
    +1
    41
    Quote Originally Posted by Dsmjske08 View Post
    Did you read the manual for directions or something else I'm putting my motor back in tomorrow and the drive shaft is my main worry about getting it back in correctly with the circlip!!??
    C-clip was my worry, but I am doing it for the second time and I did it alone for less than 30 min. Put in the pump 1/4 bit son it side and mount the pump, only do 2 oposite bolts. Then poll the hat all the way back, you will fill small resistance two times since the orings are getting in to the c-clip groove. Then you will see the c-clip groove and slide the clip. On my RXP i stayed on my knees on the back deck and was easyer than I expected. It was harder for me to take out the old c-clip since I was alone and had to hold the hat and take the clip out but it is not so bad. Good luck

  7. #6
    Thanks for the help I'll let you know how it goes tomorrow lol!

  8. #7
    TheGunMan's Avatar
    Join Date
    Feb 2013
    Location
    Las Vegas
    Posts
    454
    +1
    41
    Quote Originally Posted by Dsmjske08 View Post
    Thanks for the help I'll let you know how it goes tomorrow lol!
    Take your time. Don't rush it

    good luck

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to remove a driveshaft?
    By 01xdime in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-30-2009, 07:44 PM
  2. Stock Speedo correct!
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 06-14-2006, 10:56 PM
  3. Impeller removal, driveshaft
    By Kinchyle in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-25-2006, 08:38 PM
  4. %#[email protected]!)* Driveshaft!!!
    By 01xdime in forum 4-Tec Performance
    Replies: 14
    Last Post: 12-27-2005, 05:07 PM
  5. Anyone pulled RXP Driveshaft out?
    By RXPDAVID in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-12-2005, 05:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •