Results 1 to 10 of 10
  1. #1

    2007 RXT fault code 1502 help

    I have a 2007 RXT. I randomly get a 1502 fault, which is for the TOPS. The ski has not been tipped over. The fault stays active for awhile then clears. When the fault is active, the ski is in limp mode. Few questions: 1) where exactly is the TOPS switch? 2) am I correct that since this is an '07 that I do not have a TOPS valve but a switch instead? 3) is there away to bypass the TOPS altogether?


  2. #2

    Join Date
    Dec 2012
    Location
    MA
    Posts
    146
    +1
    12
    My 05 RXT gave me the same fault last year, and I had never tipped over as well. I cleared mine with a Candoo and then activated that tops, you can hear it click. After I did that it never did it again.
    Last edited by JohnW; 07-05-2014 at 09:26 AM.

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    The 07 tops switch, is a little black module located to the left of the fuse panel, down on the side of the mounting bracket. Below the 30A fuses, and relay.

  4. #4
    Quote Originally Posted by JohnW View Post
    My 05 RXT gave me the same fault last year, and I had never tipped over as well. I cleared mine with a Candoo and then activated that tops, you can hear it click. After I did that it never did it again.
    how did you "activate that tops"? i have had the code cleared at the dealer twice. does just cleaning the code activate the tops?

  5. #5

    Join Date
    Dec 2012
    Location
    MA
    Posts
    146
    +1
    12
    With a Candoo you can go into different tabs (menus)and this one is either under activate or settings or something along those lines, fuel pressure release is in there, activate ignition coils is, etc. I don't think that just clearing the codes fixes it. I would go to the tops relay and unplug it, see if there's any corrosion and plug it back in. And it may need to be replaced, I'm not saying that's your issue but mine had a little crud on the terminals. I don't anything about BUDS, but I do know that Candoo did it for me. On an 05 it's on the top front side of the motor. If you get the manual for an 07 online (PDF file) it will show you where the switch and or relay is. hope this helps

  6. #6
    I wish I had a CanDoo so I could try this out. Question, does the TOPS have a 3 wire connector?

  7. #7

    Join Date
    Dec 2012
    Location
    MA
    Posts
    146
    +1
    12
    I'm too slow...psycho rxp tells you where it is

  8. #8
    Ok. Found the switch. Took it off and cleaners it up. May of had some dirt or something on the connectors. Rattle it around and could here a little ball in it. Tried to listen for it clicking once I put key on, not sure if it is or not. Hard to tell over fuel pump and everything also coming on. Did not notice any broken/damaged wires. My son did mention that right before he got the 1502 fault last time, he received a 12v LOW warning. Which is odd because I always put ski on trickle charger and we got the code within 30 mins of being on the water. Now, could a low battery cause the switch to possible not get enough power and malfunction? To me this seems far fetched but who nows.

  9. #9
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by dustintinsley View Post
    Ok. Found the switch. Took it off and cleaners it up. May of had some dirt or something on the connectors. Rattle it around and could here a little ball in it. Tried to listen for it clicking once I put key on, not sure if it is or not. Hard to tell over fuel pump and everything also coming on. Did not notice any broken/damaged wires. My son did mention that right before he got the 1502 fault last time, he received a 12v LOW warning. Which is odd because I always put ski on trickle charger and we got the code within 30 mins of being on the water. Now, could a low battery cause the switch to possible not get enough power and malfunction? To me this seems far fetched but who nows.
    Possibly the battery is on its way out...?

    I just ran into a Strange problem after trickle charging the ski overnight, on mine. I got the 12V low code on the first start up on the water the next day, then my Fuel guage disappeared . Later that ride it lost power, and died. turned out the ECU went bad, and took out all 3 of my coils. It was beeping 12V low, and flashing low fuel when it had 1/2 tank left in it.
    Can u take it somewhere to get the codes read? There may be other ones u cant see stored.
    U could try to swap out the TOPS switch with a known good one to see if the codes go away, And try another battery to rule that out as well.

  10. #10
    Quote Originally Posted by psycho rxp View Post
    Quote Originally Posted by dustintinsley View Post
    Ok. Found the switch. Took it off and cleaners it up. May of had some dirt or something on the connectors. Rattle it around and could here a little ball in it. Tried to listen for it clicking once I put key on, not sure if it is or not. Hard to tell over fuel pump and everything also coming on. Did not notice any broken/damaged wires. My son did mention that right before he got the 1502 fault last time, he received a 12v LOW warning. Which is odd because I always put ski on trickle charger and we got the code within 30 mins of being on the water. Now, could a low battery cause the switch to possible not get enough power and malfunction? To me this seems far fetched but who nows.
    Possibly the battery is on its way out...?

    I just ran into a Strange problem after trickle charging the ski overnight, on mine. I got the 12V low code on the first start up on the water the next day, then my Fuel guage disappeared . Later that ride it lost power, and died. turned out the ECU went bad, and took out all 3 of my coils. It was beeping 12V low, and flashing low fuel when it had 1/2 tank left in it.
    Can u take it somewhere to get the codes read? There may be other ones u cant see stored.
    U could try to swap out the TOPS switch with a known good one to see if the codes go away, And try another battery to rule that out as well.
    yeah, local seadoo dealer read codes. only the 1502 and it was not active, it was an occurrence. so a failing battery could be the cause of the 1502 fault? if i had another tops switch i would try it, just trying to avoid spending $60 on a part i don't need, you know.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 Seadoo RXT X 260 as Fault Code Please Help!
    By Addog01 in forum 4-Tec Performance
    Replies: 3
    Last Post: 12-09-2013, 06:38 AM
  2. 2005 rxt fault codes
    By hognut2000 in forum 4-Tec Performance
    Replies: 21
    Last Post: 04-19-2012, 05:31 PM
  3. Fault code 15 help r12x
    By slightlyfastR12x in forum Honda How To & FAQs
    Replies: 1
    Last Post: 07-14-2010, 09:30 AM
  4. RXP fault codes. Need Help
    By rxp127 in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-27-2010, 01:37 PM
  5. 2007 rxt homemade intake ? please help
    By jamesrini79 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-19-2007, 04:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •