Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1

    2004 RXP trouble

    Hey whats up everyone. So i am new here I just purchased a 2004 RXP and with my luck already having issues with it before i even got to take it out. So today i have it dropped in the water first time after buying it. The previous seller told me its water ready everything functions perfect. So after getting some gas and slowly getting out of my marina i make it about 400 yards out give it just a little bit of throttle maybe 1/4 way and it died. And it will not turn over. The battery is good its brand new. The dash lights up everything seems fine till i try starting it it just makes one knock sound. Engine will not turn over. So far I was told it could be something blocking the impeller. I put my had under there but could not feel anything. I hope someone can give me so possible options on what i should look into or what it can possibly be. Any help is greatly appreciated.


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Pull the spark plugs first. Could have dropped a valve....the plug will be damaged, or will be hard to remove. If that looks good, then pull the Supercharger, and see if its locked up. That will kill the motor, and not let it turn over.

    How many hours on the ski?
    Has it sat for a long time?
    When was the Supercharger rebuilt last?

  3. #3
    Common issue is the starter solenoid. Pop the front hood up, pull the storage bin and there is a brown solenoid oposite the battery. Tap on it a couple times while hitting the start button. See what that gets ya

  4. #4
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by Lostkause17 View Post
    Common issue is the starter solenoid. Pop the front hood up, pull the storage bin and there is a brown solenoid oposite the battery. Tap on it a couple times while hitting the start button. See what that gets ya
    That would not make the engine while accelerating..

    It could keep it from restarting, but the engine should not stall, or lock up while running, unless something bad happens.... Hopefully not, but it is an 04"

  5. #5
    Quote Originally Posted by psycho rxp View Post
    Pull the spark plugs first. Could have dropped a valve....the plug will be damaged, or will be hard to remove. If that looks good, then pull the Supercharger, and see if its locked up. That will kill the motor, and not let it turn over.

    How many hours on the ski?
    Has it sat for a long time?
    When was the Supercharger rebuilt last?
    Thanks, It has a 100hrs, it sat since last season but had an oil/filter changed this year. Supercharger was rebuilt less than 5 hrs ago. Thanks a lot for the help so far I will try to pull the spark plugs today and see how they look.

  6. #6
    You didn't ride it before you bought it?

  7. #7

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    Sounds like a dropped valve to me. The back spark plug will probably be smashed. Hope I'm wrong...

  8. +1 by:


  9. #8
    I should also mention the jetski has a stage 1 riva kit installed. Not sure if that makes any difference. And while riding upon giving just a tiny bit of throttle i would notice a little white smoke come out the back, i was told this is normal.

  10. #9
    Nope the guy just started it up for me. I know big mistake. Learned the hard way.

  11. #10
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    The valves in 04-05' were famous from rusting/ pitting from sitting too long without use. Then when started up, some would break off the exhaust valves, and trash the head, & pistons. SOme would even crack the cyls, and require another block. Hopefully the SC locked up, or came apart, and locked the flywheel. Unfortunately, that would be the better of the 2 senerios, but could be fixed cheaper. neither failure will be cheap tho....

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 RXP trouble starting in water
    By CBRXP in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-11-2014, 09:45 AM
  2. 2004 RXP Paint Codes
    By Thomas in forum Sea Doo How To & FAQs
    Replies: 5
    Last Post: 07-23-2007, 12:14 AM
  3. 2004 RXP - "MAINT" flashes on Dashboard
    By premlulla in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 02-07-2007, 12:21 PM
  4. 2004 RXP vs. 2005 RXP
    By Teddy57 in forum 4-Tec Performance
    Replies: 14
    Last Post: 12-03-2005, 03:54 PM
  5. This can't be right... 2004 rxp with 5 hours for $3K
    By Enufpwr in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-25-2005, 09:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •