Results 1 to 2 of 2
  1. #1
    theswits's Avatar
    Join Date
    Aug 2007
    Location
    BC, Canada
    Posts
    20
    +1
    1

    STX 12f Blowing fuses, no spark

    Hi all, a friend's 2007 12f is just prepping it for the year. Have a problem blowing the main 20A fuse. We change the fuse, get the two beeps from the display. We can then crank the engine, its turning over great, but its not firing. Sounds like no spark. When the ignition button is released, the fuse seems to blow simultaneously. We then replaced the fuse and the whole procedure repeats itself. We have gone through 4 fuses now, so its very repeatable. The battery is new, fresh and charged. After replacing the fuse, the starter will turn over the engine for up to 15 seconds at time (don't want to go longer, don't want to fry the starter). But the fuse blows as soon as thumb releases the start button. Friend had it winterized at stealership last year. Heavily fogged entire interior of engine well. Friend reported that he ran water through the ski for 5-10 minutes when he first took it out of storage earlier this week. I suspected hydro-lock. So we took out the plugs, checked for hydro-lock, no problems found. Removed intake drain bolt, no problems found. Oil looks clear and clean. Any ideas how to troubleshoot this B***h? Thanks, E.


  2. #2
    theswits's Avatar
    Join Date
    Aug 2007
    Location
    BC, Canada
    Posts
    20
    +1
    1
    OK, weird problem, but found the solution. wire to Injector #3 was pinched under wire holder, fault to ground. No work has been done on injectors, very strange how wire got pinched under clamp. Problem solved.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GP1200 Keeps Blowing Stator, No Spark.
    By gvsu141 in forum Yamaha Old School Skis
    Replies: 10
    Last Post: 07-08-2015, 11:55 AM
  2. 2007 STX-12F No spark
    By termite68c in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 07-17-2014, 12:08 PM
  3. 05 STX 12F no fuel or spark to #1 & #4
    By Chris Sadler in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 08-08-2013, 11:30 PM
  4. 2005 STX 12F No fulel or spark to #1 and 4 cylinder
    By aleskypr in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 07-15-2013, 11:55 AM
  5. Kawi 1100 STX DI that has no spark
    By Baron62 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 17
    Last Post: 07-18-2012, 08:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •