Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    My son (mohawk man) jeffsntx's Avatar
    Join Date
    Sep 2006
    Location
    Belton TX
    Posts
    2,598
    +1
    1

    Thumbs up WFO Performance and my new numbers

    I made a 180 mile trip to do some testing with my yellow project ski on WFO's testing grounds. I got to his place Saturday afternoon about 1:00. When I got there he waas working on another customers ski but took the time to point out a few little things on my ski, like ride plate angle, and shimming the tabs. After he told me what I need to look for and do, I started wrenching on the things he pointed out to me. After I got my ski where he thought it should be I spent the rest of the day just watching WFO do his magic on the customers ski. This man is EXTREMELY thorough with his work. WFO provided me a place to stay for the night, and the next morning he continued on the customers ski.

    At about 12:00 we left his house and headed for the water so that he could dial in the customers ski that he was working on and do some riding. I set the Jetworks on my ski and then he set the Jetworks on his customers ski. Then we started to do a little riding. Me on my yellow project, WFO on my pretty stock 02 GPR and his customer on his ski. We had a blast!! My ski ran 74.6 on a 1200 grate and a half tank of fuel!! We didnt have the time to do any other adjustments on my ski after the last ride we went on so this thing still has a little speed left in it.

    A BIG thanks goes out to WFO performance for his hospitality and the help on my project.


  2. #2
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Congrats on the new #s Jeff! Thats like and 6mph gain in the past couple weeks right?

    Thats great for an unported 1200 with a 1200 grate. I am sure there is still more there with some fine tuning.

    What were the temps? Rpms? Conditions?

  3. #3
    My son (mohawk man) jeffsntx's Avatar
    Join Date
    Sep 2006
    Location
    Belton TX
    Posts
    2,598
    +1
    1
    The temps were in the lower 80's, WFO and I are still a little confused about the RPMs. We tried several settings on the PET 2100 and can not seem to get it to read correctly throughout the RPMs. We can get them correct on the lower RPM's but its way off on the higher RPMs or vise versa. The last time I looked at the tach it was reading about 7080 so I think I am pretty close with the box stock DF 14/20. I am starting to think that the plug wires that I am running might be playing tricks on the PET tach. The water conditions were OK. There was a LOT of crud floating in the creek, it was pretty smooth but far from glass. I cant wait to get back down that direction and do some more riding with the locals.


    EDIT: This project doesnt even have a good ride plate on it yet!!!
    Last edited by jeffsntx; 04-02-2007 at 09:30 AM.

  4. #4
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    I had a great time Jeff. You were the perfect guest.

    I still cant believe the mid-range on that little 1200... WOW !

    We were kinda nuts trying those top end runs in that wind and chop.

  5. #5
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Quote Originally Posted by jeffsntx View Post
    The temps were in the lower 80's, WFO and I are still a little confused about the RPMs. We tried several settings on the PET 2100 and can not seem to get it to read correctly throughout the RPMs. We can get them correct on the lower RPM's but its way off on the higher RPMs or vise versa. The last time I looked at the tach it was reading about 7080 so I think I am pretty close with the box stock DF 14/20. I am starting to think that the plug wires that I am running might be playing tricks on the PET tach. The water conditions were OK. There was a LOT of crud floating in the creek, it was pretty smooth but far from glass. I cant wait to get back down that direction and do some more riding with the locals.


    EDIT: This project doesnt even have a good ride plate on it yet!!!
    80s and a non modded plate!!!!

    Those tachs can be sensitive especially in salt conditions. You need to keep the pickup wire away from the others as best as possible. I robbed a tiny tach wire and it worked perfect.

    I am thinking you turning more rpms then that. My 12 turns that prop in the upper 7200 area at 75.

  6. #6
    My son (mohawk man) jeffsntx's Avatar
    Join Date
    Sep 2006
    Location
    Belton TX
    Posts
    2,598
    +1
    1
    Quote Originally Posted by Duke View Post
    80s and a non modded plate!!!!

    Those tachs can be sensitive especially in salt conditions. You need to keep the pickup wire away from the others as best as possible. I robbed a tiny tach wire and it worked perfect.

    I am thinking you turning more rpms then that. My 12 turns that prop in the upper 7200 area at 75.

    I think there is still a few more MPH in the ski easy. Like I said, I havent done ANY engine tuning yet. After the workout that it got this weekend it should have a good wash pattern to look at so I can make some adjustments. I will probably try someones plate to see if I can get a couple of MPH that way. The plate that is on it is the old style Riva that I have done nothing to except true the center and grind to the correct angle. Then I will take the stock plastic tabs off, try some others, and try to gain a little there too. This should be an awesome upper 70's ski when all of the fine tuning is done I hope.

  7. #7
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    Its going to be a fast one when you are done Jeff. Lots of little stuff left to do.

    Damn that thing is peppy !

  8. #8
    RAIDER RUNNER BULLRAIDER's Avatar
    Join Date
    Nov 2005
    Location
    HOUSTON TEXAS
    Posts
    651
    WFO .where did y'all test at ??

  9. #9
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    Egret Bay... it was windy and choppy, so we went down the creek past Walter Hall to Challenger Park (I think thats what its called)

  10. #10
    RAIDER RUNNER BULLRAIDER's Avatar
    Join Date
    Nov 2005
    Location
    HOUSTON TEXAS
    Posts
    651
    It was that bad when we ran the other day also, I know where you are talking about now....

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Intro and my new 780
    By 1low59 in forum Polaris Open Discussion
    Replies: 18
    Last Post: 04-13-2008, 01:20 AM
  2. My New Numbers
    By IowanGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 05-29-2007, 07:00 AM
  3. First day and my new RXT runs like POOP!
    By 2006 RXT in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-09-2007, 11:16 PM
  4. pics of me and my new raider
    By big raider in forum Yamaha Old School Skis
    Replies: 27
    Last Post: 03-01-2007, 03:10 PM
  5. RXT and my new prop
    By Kinchyle in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-27-2005, 09:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •