Results 1 to 6 of 6

Thread: help with boost

  1. #1
    fun rider's Avatar
    Join Date
    Jul 2014
    Location
    hartwell ga
    Posts
    79
    +1
    3

    help with boost

    Can someone pls tell me how must boost an 14 fzs svho makes from factory i cant find anything that says it and i really want to know


  2. #2
    10

  3. #3
    fun rider's Avatar
    Join Date
    Jul 2014
    Location
    hartwell ga
    Posts
    79
    +1
    3
    Thanks been searching for a few weeks but couldnt find anything

  4. #4
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376

  5. #5
    zone5's Avatar
    Join Date
    Feb 2013
    Location
    West of Blue Mountains, Australia
    Posts
    373
    +1
    36
    I think shrabber has it. I had a hose come off at WOT, as the water level dropped and uncovered the first temp sensor I got a warning and stopped the motor straight away. Anyway, point of this is that when we took it to the shop and dumped the ECU to check for codes (none, thankfully), the last sixty seconds running were in the log, and according to the ECU itself it was boosting about 10.5 psi (converted from HPa) at 7600 rpm BUT at 3000' AMSL, this means the ambient pressure at supercharger intake is about 9-10% less than sea level. That would equate to around 12 "ish" psi normally....
    Last edited by zone5; 07-09-2014 at 01:00 AM.

  6. #6
    fun rider's Avatar
    Join Date
    Jul 2014
    Location
    hartwell ga
    Posts
    79
    +1
    3
    Ok has any one changed the impeller on supercharger to build more boost on stock motor and have u had any problems with blown head gasket?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with C-KIT (low boost)
    By elbchecker in forum 4-Tec Performance
    Replies: 14
    Last Post: 08-29-2008, 11:07 AM
  2. Hey Guy's need help with Boost Gauge sender
    By somefun in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-19-2007, 07:34 PM
  3. Need help with pump issue
    By Flyer in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-23-2006, 05:40 PM
  4. Need help with 04 S.C. rebuild
    By Turbo Todd in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-10-2006, 08:03 PM
  5. Help with Riva air filter kit
    By 818RXP in forum 4-Tec Performance
    Replies: 20
    Last Post: 08-19-2005, 06:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •