Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    Oheezy404's Avatar
    Join Date
    Jan 2014
    Location
    Kansas
    Posts
    238
    +1
    21

    Postive advice needed from racers ASAP.... Kaw 250x

    So I just returned from beautiful Kentucky Lake and the races...... My O MY were my times all over the place. My tuner and I spent more time wrenching on the ski this weekend then we have past three race seasons...... First off as many of you know I was headed to Kentucky Lake to race with a brand new Supercharger installed the evening before we left..... Friday when I arrived I immediately got the ski on the water for about 30 min before dark. 4 things I noticed in that time were as follows. The ski slipping which appeared to be from loose belt. The ski hitting the revlimeter. The ski cavatating like crazy. The ski burping as if bad fuel aka water.
    Saturday was qualifying . Our first pass we ran a lousy 16 sec pass at 59 mph. Some of the things I noticed was bad cavatating. As well as the ski hitting the revlimiter at 125 feet and at 250 feet. I also noticed the ski burp as if bad fuel again. I also noticed about 6 slipages which I believe were from a loose belt. The next pass we put some heat in the fuel along with a few other things. We tightened the belt a little bit with what tools we had. That pass we ran a 15.40 at 63 mph or so. Things I noticed this pass were the ski hitting the revlimiter off the holeshot and again at 125 feet. Then I noticed a few slipages again down the track which slowed me down. The next pass we ran 15.30 at 64 mph. The ski cavatating again. Things I noticed this pass were the ski hitting the revlimiter at 125 feet again. Then a burp down the track from water in the fuel bad gas I think. Then two more slipages. As each slip or burp or revlimiter issues it brought the ski backwards as in slowing it down. The next pass we ran a 15.20 at 64 mph again. We had tighten the belt up before the pass even more. The ski once again hit the revlimiter at 125 feet and burp down the track . This time it did not slip at all due to tighter belt we believe.
    Sunday came along and again I had to take a stab at a dial in. I dialed in at 15.100 We ran 15.105 but unfortunely we red lighted bye -0.100 barely. And we were sent back to the trailer early. Things I noticed that pass was the dam ski Not hitting the revlimiter at 125 feet which I had compensated for all weekend bye leaving a little early on the light. The ski did burp one time which appeared to be from fuel issue. I then asked for a test and tune pass to put more time on the ski. That pass the ski ran great at 65 mph and ran a 14.91 e.t . Crazy how it was tuned after each pass and improved 6 mph on time tickets bye the end of the race weekend.
    So here are a few things I may or may not look at or do before my next race in 3 weeks in Chouteau, OK. Burn all old fuel out and not refuel until the day of the race. May put 4 more new plugs in. May take a good look at the jet pump assembly to see if I may off ran it up on anything in the past month riding around for rec time. Might remove the R&D ride plate or intake grate and put stock one back on. Might buy the right tool to tighten the belt up. Might send the ECU in to increase the rpms to R&D or Riva to avoid rev limiter issues. I will try to put some more time breaking in Supercharger as well. For sure going to turn ski into racing ski only as its costing too much money this year......

    I am open for positive ideas slash feed back. My points lead is down to 1 round with 5 races left so it's dam important to me to get these glitches fixed in 3 weeks.
    If anything I said is confusing or misspelled sorry been at work 16 hours now....

    Ryan


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Get the belt tool as i suggested when you got the new s/c and I bet all your other issues will disappear all your issues are belt related, I cant believe as a racer you dont already have it

  3. #3
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Oh and get another tuner he seems to be offering no real help on the running of your ski lol

  4. +1 by:


  5. #4
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    I knew you were changing too many things. Your SC is fine. It is making boost if you are hitting the limiter that quickly. Y'all may not have set the rubber pump ring properly or something else when changing all those parts causing the ski to cavitate. Like it was said in your sport quit chasing speed and keep it consistant. Yes it cost you a fortune this year and a race because of doing things that were not beneficial to your ski and your sport. Even in my sport. My ski is about 5 mph than some of my competition but the consistancy and hook up make up for all that. Fastest is not always faster especially in your sport.

  6. +1 by:


  7. #5
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Do you have the videos from this race you are talking about to hear what you are talking about?

  8. #6
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Really sounds to me to be all boost/loose belt related, and maybe a bad sparkplug, I cant imagine fuel being the problem unless you guys really do have poor quality fuel over there. With a tight pump/prop a new s/c you should have zero cavitation and an arm wrenching pull.

  9. +1 by:


  10. #7
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Also with the SC going out, did you clean out the inter cooler? Are all the hoses on properly along with hose clamps tightened? Was the belt replaced? Is all the exhaust put back properly? All hoses and clamps checked?
    Biggest rule of racing if it ain't broke don't fix it. Especially not during the season. All that your ski needed was the impeller and pump prior to this season. Off season is the time for modding and testing. Did you not go test your ski before this race? How knowledgable is your mechanic about skis and their performance? Did he test the ski after the repairs? Why was the ski returned to you running this badly? It is just almost impossible for us to offer much advice when so much was just done to the ski.

  11. #8
    Oheezy404's Avatar
    Join Date
    Jan 2014
    Location
    Kansas
    Posts
    238
    +1
    21
    Quote Originally Posted by lasportsmn View Post
    Do you have the videos from this race you are talking about to hear what you are talking about?
    I have 5 videos on my go pro but I was not wanting to take the time to put them all on you tube just to send the links out. I do have them on my computer if there is another way to send them or post them let me know. You will clearly be able to watch the stoppages in the ski as well as the slipages and all the burps if you were to watch them closely. Each burps affects my time as you know.... I did my best to guess times all weekend....

    Ryan

  12. #9
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    I wish i did but I just dont know anyone in your area I can ask to go help you get this sorted out.
    If you can just email the videos to me and I can check them out?

  13. #10
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    I think your onto something gl, lots going on there manifolds would have been removed also, suggesting a possible water leak, lots to check out and only ryan can do it. Work should have included new exhaust gaskets, new belt, new idler bearing, along with new s/c and tension tool. I/c clean, and all boost hoses double checked for tightness. Along with the pump being installed correctly.

  14. +1 by:


Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kaw 250x with lots of new mods on it and needing good advice.
    By Oheezy404 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 07-22-2014, 05:24 AM
  2. Looking at buying a 04rxp for a gprxp project advice needed asap!
    By RXPSTUNNA in forum Conversion FAQ and Tips
    Replies: 2
    Last Post: 07-09-2010, 02:06 PM
  3. Need advice - upgrade from 215 to 255 setup?
    By Jim-C180 in forum Sea Doo Sport Boats
    Replies: 21
    Last Post: 03-22-2010, 12:22 PM
  4. Advice needed from the big dogs, Lets talk Head work!
    By boostaholic in forum 4-Tec Performance
    Replies: 1
    Last Post: 12-25-2007, 06:43 PM
  5. First Ride Report From IRELAND! Advice needed
    By Scatman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 05-02-2007, 02:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •