Results 1 to 9 of 9
  1. #1

    Join Date
    Feb 2006
    Location
    Cape May
    Posts
    626
    +1
    17

    2010 Plastic on driveshaft peeling

    My driveshaft is peeling, some missing spots and loose spots of the plastic coating, should I try to peel off the rest of what is loose?

    I plan to upgrade to old style over the winter


  2. #2
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    I would just trim it where needed unless your getting vibration issues. How many hours on that shaft? I was lucky to go over 100 but a lot failed before that. You might want to start looking at ordering parts or always ride with a "tow partner"

  3. #3

    Join Date
    Feb 2006
    Location
    Cape May
    Posts
    626
    +1
    17
    97 hours just pulled pump last week and spline looks ok, cleaned it up and grease it, although the dried up grease i removed stuck to a magnet pretty good so its got some wear.

    already got the shaft will be getting other parts soon

  4. #4
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Good deal. I did plenty of greasing and ran a nose cone which I think helped a bit, but unfortunately it's a "when not if" issue with those shafts. PLUS the screw type shafts are a PITA compared to the c-clip type. I still have my old shaft if ya want a back up lol.

  5. #5

    Join Date
    Feb 2006
    Location
    Cape May
    Posts
    626
    +1
    17
    Lol , If I have to pull it the old style is going back in. how hard is it to take out the screw type? I am familiar with the old style and have the tools for that

  6. #6
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    I used a pipe wrench to hold the old shaft(through the intake) and a old "nut wrench" to break it loose. Not sure the exact size. It wasn't going back in at that point...

  7. #7

    Join Date
    Feb 2006
    Location
    Cape May
    Posts
    626
    +1
    17
    righty tighty or lefty lucy?

  8. #8
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    LOL...it has left handed threads so - righty loosy
    Your pump is mounted to the rideplate right? I have the whole alignment kit if ya ever get in a jam. I'm about 1 1/2 hours away.

  9. #9

    Join Date
    Feb 2006
    Location
    Cape May
    Posts
    626
    +1
    17
    Yes its mounted on rideplate, Thanks for the offer, after reading about alignment on here thinking about checking both ski's over the winter.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Painting Plastic On Waveraider
    By Adam E. in forum Yamaha Old School Skis
    Replies: 13
    Last Post: 12-02-2009, 08:00 AM
  2. RXP-X light surface rust on driveshaft
    By lethal_inj in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-08-2009, 10:13 PM
  3. Plastics on top of engine are useless and cause rust
    By Gus13letter in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-29-2008, 07:48 PM
  4. Crack plastic on bow eye
    By jreynoldsqaz in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-14-2008, 10:47 PM
  5. Pressing on driveshaft
    By thirdgen327 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-28-2006, 02:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •