Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1

    Start/stop switch

    So just took my virage I out today after getting it all Back together and running on the trailer and put it in the water and can start it with the start switch but can only stop it with with the kill swith so I'm going with the switch is bad just wanted somebody to confirm my thought. Thanks ben


  2. #2
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    That part lr505 that comes up in some discussions could that be my start/stop problem and does that also run my bilge pump cause when I plug it in it starts automatically and will not stop till I unplug it thanks for all the help Ben

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    The LR-503 Start/Stop module (LR-505 on carburetor models) controls the bilge pump (Orange wire output) plus engine Start/Stop via the single Start/Stop button.

    It sounds like your LR module has failed.

  4. #4
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    Ok do u know where is a good place to buy one at and it's for a 02 virage I 800

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by ben01251979 View Post
    Ok do u know where is a good place to buy one at and it's for a 02 virage I 800
    There is a Parts Sources list via my signature links.

  6. #6
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    I was able to find one off your signature link thank u and this is what mine looks like after I got it out
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20140709_154850.jpg 
Views:	45 
Size:	42.8 KB 
ID:	335354  

  7. #7
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    Not a good picture but on the left side it's all melted and oozing out

  8. #8
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    That just looks like the potting that holds the whole thing together.

  9. #9
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    I believe that is what is melting and coming out of the plastic housing but don't know what exactly got hot on the inside and caused that but from what I been told that little box runs my start/stop switch which only starts the ski now and my bilge pump which runs all the time when u plug it in

  10. #10
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    If the bilge pump constantly runs with the engine off then yes you have a bad module.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB: Sea Doo SP (95') Start Stop Switch ASAP
    By Hybrid AWD in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 08-28-2012, 09:00 AM
  2. GPRXP Start/Stop switch modification
    By Hydrotoys in forum Conversion FAQ and Tips
    Replies: 28
    Last Post: 10-13-2010, 05:06 PM
  3. Umi start stop switch
    By tngibbs in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 10-25-2008, 11:22 PM
  4. How to take apart and clean Start/Stop switch??
    By Old Atari Nut in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-27-2008, 09:27 AM
  5. 95 XP and 95 SP Start/Stop Switch Interchangeable?
    By Hybrid AWD in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-27-2008, 02:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •