Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    "normal" engine operating temps?

    What's the "normal" safe engine operating temps for a closed loop 4tec?

    At what temp should I start to worry about the block?


  2. #2
    Sanfish's Avatar
    Join Date
    Jun 2014
    Location
    S/E Florida
    Posts
    2,540
    +1
    778
    When I had OEM thermostat, it would range between 188' to 196' in 80/83-deg water (ocean).

    After installing a 160' thermostat (Riva kit), it now runs 156' to 165' max! Best feel good mod to date!

    But to answer your question, if the temps go above 200' something is wrong and should be addressed. Not that 200 will damage motor but for how low in RPM you are spinning, you should never see much above thermostat opening. Especially in the cold waters where you live.


  3. #3

    Join Date
    Jul 2012
    Location
    Northern VA
    Posts
    215
    +1
    18
    Wish they would put gauges on these dam things .....oil psi....boost....water temp....volts

  4. #4
    Quote Originally Posted by 4skis View Post
    Wish they would put gauges on these dam things .....oil psi....boost....water temp....volts
    Pre warned is pre armed, so BRP wouldn't want to lose all those lucrative dealer network repair $$$$$

    No, we should blindly run our $20k investment, with poorly engineered solutions which don't fail safe, and hope all's well. If it goes bang, don't worry BRP will be there for you ready to repair. Perfect. (the small matter of the repair bill is just picky detail, we got you back on the water again didn't we?!!). Mr Bitter writes.

    CMD LCD-200 is the way forwards - tap into the coolant temp sensor and you get the real engine temp - hence my question..

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by 4skis View Post
    Wish they would put gauges on these dam things .....oil psi....boost....water temp....volts
    mine has gauges.....
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	118.jpg 
Views:	85 
Size:	106.4 KB 
ID:	335378  

  6. #6
    Quote Originally Posted by Snoman View Post
    Quote Originally Posted by 4skis View Post
    Wish they would put gauges on these dam things .....oil psi....boost....water temp....volts
    mine has gauges.....
    Neat, but I see it also has an equestrian dressage lever!!

  7. #7
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,378
    +1
    981
    Quote Originally Posted by Snoman View Post
    Quote Originally Posted by 4skis View Post
    Wish they would put gauges on these dam things .....oil psi....boost....water temp....volts
    mine has gauges.....
    same here:
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0691.jpg 
Views:	83 
Size:	67.1 KB 
ID:	335380  

  8. #8

    Join Date
    Jun 2014
    Location
    Ontario, Canada
    Posts
    17
    +1
    1
    That's exactly what I need. Did you make the pod yourself? Just bought an '07 RXP and can't, for the life of me, understand why there's no temp gauge

  9. #9
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,378
    +1
    981
    JLewis makes the glovebox cover, WFO did the install. Others have installed gauges in the mirror pods, which is actually a better place for gauges as there is no need to look down to view them when at speed.

    The cover is available at the store:
    http://www.4-tecperformance.com/inde...over&x=12&y=18

    I think WFO has an RXP 2 gauge cover in stock...call him
    Last edited by 1tommygunner1927; 07-10-2014 at 10:28 AM.

  10. #10
    Or just connect a vtech datalogger and you get all sensors live and can record them

    Connects easy via Diagnosis connector.

  11. +1 by:


Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 rxp Normal running engine temp
    By vicario62590 in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-16-2014, 02:42 PM
  2. Normal Operating Temp 95 SL750 Stock?
    By RIVER BOY in forum Polaris PWC Performance
    Replies: 27
    Last Post: 07-26-2013, 06:57 PM
  3. Operating Temp Range of 4Tec motor...
    By Danny in forum 4-Tec Performance
    Replies: 11
    Last Post: 10-15-2007, 02:13 PM
  4. 1200 Tripple Operating Temp???
    By VegasRatt in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-03-2007, 10:46 PM
  5. Engine Water Temp?
    By SpeedJunky in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 01-25-2007, 04:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •