Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    98 Kawasaki STX 1100 (GAS TANK HOSES)

    Had to remove gas tank to get rid of 10 year sitting fuel. Can't figure out where the 3rd hose goes from the top of tank. Does anyone know where all 3 hoses go. I have 2 right I think but the one that point to the front of the craft I cant figure out!!!

    Thres two pointed toward engine, I believe I got those right cuz it ran for 20 min. today on the reserve tank, but when that tank went dry and I put it to the ON position no more fuel comes through the line. I even put a brand new filter on is and I can see that NO FUEL is making it to the filter.

    Pretty sure I have a line wrong or I need to find where the third one goes...

    Click image for larger version. 

Name:	20140711_145805.jpg 
Views:	98 
Size:	61.4 KB 
ID:	335498


  2. #2

    Join Date
    Jun 2014
    Location
    MS Gulf Coast/Abbeville, LA
    Posts
    170
    +1
    17
    dont know the specifics of your ski, but on mine, i have a reserve line, main line, and return.. someone else may chime in with more/better info

  3. #3
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    On that model, the fuel selector is in the fitting on top of the tank. It is cable operated. There is only one line going to the carbs, the one that goes through the fuel filter. The other line to the carbs is the return line. The third is the vent hose. It comes from above the tank and goes out by the handlebars.

  4. #4
    thanks Steve, so inside and up towards handlebars??

  5. #5
    Also steve I seem to get no fuel when Im on ON but I get fuel on reserve what could that be is it the unit itself? Inside the tank? Its had gas sitting in it for 5 years!! I cleaned it all out and it runs perfect, but only on the reserve setting. Thanks for your help!!!

  6. #6
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    You may have a clogged pickup. You may have to pull the pickup from the tank and clean/replace the filters.

    The vent line runs along with the wiring harness up to the handlebars. I don't know if there are any pictures of it. Look around and you'll probably find a hose coming down from above.

  7. #7

    98 1100 STX vent line off of gas tank

    Quote Originally Posted by steve45 View Post
    You may have a clogged pickup. You may have to pull the pickup from the tank and clean/replace the filters.

    The vent line runs along with the wiring harness up to the handlebars. I don't know if there are any pictures of it. Look around and you'll probably find a hose coming down from above.

    So does that vent hose have a 1 way check valve on it ?
    Doesn't it need one to keep the ski the correct pressure ?

  8. #8
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    I would think so, but I don't see one in the drawing. In fact, I'm not positive that I'm even looking at the correct hose in the drawing (poorly drawn). I supposed it's possible that the check valve might be made into the fuel pickup assembly.
    Last edited by steve45; 08-18-2017 at 02:35 PM.

  9. #9
    DavidR's Avatar
    Join Date
    Jul 2013
    Location
    Forney,Tx
    Posts
    777
    +1
    45
    Quote Originally Posted by mdog View Post

    ... it ran for 20 min. today on the reserve tank, but when that tank went DRY and I put it to the ON position no more fuel comes through the line. I even put a brand new filter on is and I can see that NO FUEL is making it to the filter.
    Because of this statement right here, your question doesn't make sense to me. You ran it out of fuel in reserve then you switch it to 'on' and you are asking why there is no fuel getting picked up??

  10. #10
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    HA! I need to read more carefully!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. kawasaki 1997 stx 1100 tubing and hose question
    By suzuki4444 in forum Kawasaki Projects
    Replies: 2
    Last Post: 04-01-2013, 05:19 PM
  2. Kawasaki STX 1100 D.I. Low Fuel light ON - Full Tank
    By koryk in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 08-18-2010, 07:12 AM
  3. SL 780 Gas Tank hose configuration
    By WaveChaser in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-17-2009, 01:59 PM
  4. 2002 Kawasaki stx 1100 DI, Won't Start
    By Ken in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-30-2009, 11:44 AM
  5. Parting out 1997 Kawasaki STX 1100
    By waterdoglouie in forum Kawasaki Classifieds
    Replies: 16
    Last Post: 05-14-2009, 01:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •